Nach Update auf Version vom 25.08. > Backend in Englisch

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
Post Reply
Old Boy
Posts: 1197
Joined: Fri 23. Nov 2012, 13:52

Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Old Boy »

Egal, welche Sprache ich beim LogIN auch einschalte, ich lande immer in einem ENGLISCHEN Backend!

Hab ich ggf. etwas übersehen?
In der config-Datei habe ich nur die zusätzlichen Zeilen eingefügt, ansonsten dort alles andere belassen.
User avatar
Uwe367
Posts: 1140
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Uwe367 »

Kann ich bestätigen.
XAMPP spuckt mir im Browser eine Fehlermeldung aus die sich auch in der php Error Log wieder findet:
Warning: Undefined array key "ref" in D:\xampp\htdocs\test2\login.php on line 77

Ich erstelle mal ein Issue......

[EDIT]
Gerade getestet.. bei einer Neuinstallation passiert das gleiche.
[/EDIT]
Old Boy
Posts: 1197
Joined: Fri 23. Nov 2012, 13:52

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Old Boy »

Ein weiteres Problem:

Auf dem localhost MAMP mit Safari läßt sich kein login bewerkstelligen :?
Es kommt die Meldung: Fehler beim Anmelden!

Mit Firefox klappt es allerdings einwandfrei :D
User avatar
Oliver Georgi
Site Admin
Posts: 9792
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Oliver Georgi »

Der Sprachwahl-Fehler ist behoben. Sorry, ist mir nicht aufgefallen.

Es wurde das gesamte Verhalten hinsichtlich des Initialisierens der Session etc. geändert. Darauf achten, dass alle PHP Session Cookies gelöscht werden, bevor man sich wieder anmeldet. Möglichst PHP 7.3+ nutzen. Ansonsten mal posten, für welche PHP Kombination es Probleme beim Login gibt. Für mich funktioniert das Anmelden unter Safari.

Es werden jetzt erweiterte Cookie Einstellungen gesetzt: Secure, SameSite und httpOnly.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
User avatar
Uwe367
Posts: 1140
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Uwe367 »

Mit dem letzten Bugfix ist das Sprachproblem erledigt, jedenfalls auf meinem Localhost mit XAMPP unter PHP 8.0.8.
Danke fürs schnelle erledigen :D

Was Safari betrifft, da kann ich nicht mitreden da dieser nicht mehr für PC weiter entwickelt wird.
Aber Firefox, Edge, Chrome und Opera, jeweils die aktuellen Versionen, machen keine Probleme.

Allerdings ist die Warning nach wie vor in der php error log zu finden:
PHP Warning: Undefined array key "ref" in D:\xampp\htdocs\test3\login.php on line 77
User avatar
Oliver Georgi
Site Admin
Posts: 9792
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Oliver Georgi »

Uwe367 wrote: Fri 27. Aug 2021, 06:04Allerdings ist die Warning nach wie vor in der php error log zu finden:
PHP Warning: Undefined array key "ref" in D:\xampp\htdocs\test3\login.php on line 77
Ist erledigt, hatte POST/GET übersehen.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
User avatar
Uwe367
Posts: 1140
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Uwe367 »

Oliver Georgi wrote: Fri 27. Aug 2021, 06:58 Ist erledigt, hatte POST/GET übersehen.
Danke :)
Old Boy
Posts: 1197
Joined: Fri 23. Nov 2012, 13:52

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Old Boy »

Auch hier: SPRACHE ist jetzt wieder umschaltbar ... PRIMA und danke!

Aber weiterhin gilt:
Auf dem localhost MAMP und PHP 7.4.16 mit Safari läßt sich kein login bewerkstelligen :?
User avatar
Oliver Georgi
Site Admin
Posts: 9792
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Nach Update auf Version vom 25.08. > Backend in Englisch

Post by Oliver Georgi »

Old Boy wrote: Fri 27. Aug 2021, 18:07Aber weiterhin gilt:
Auf dem localhost MAMP und PHP 7.4.16 mit Safari läßt sich kein login bewerkstelligen :?
Kann ich nicht nachvollziehen. Prüfe saubere Einstellung für SSL in der conf.inc.php, Browsercache/Cookies komplett löschen. Welche Safari Version, welches macOS, Fehlermeldungen im Browser beim Anmelden, PHP?
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
Post Reply