Page 1 of 1

[SOLVED] Setup unter PHP 8.1.2 bricht bei Datenbank Einstellungen ab

Posted: Tue 22. Feb 2022, 18:22
by dani
Ich hatte meine Dev phpwcms Umgebung unter php 8.1.2 (Plesk) laufen. War eine Kopie der Live Seite, ohne das Setup auszuführen.

Jetzt wollte ich eine Neuinstallation per Setup PHPWCMS SETUP VERSION 1.9.32, RELEASE 2022/01/31 machen und da kam beim bestätigen von Punkt 3. MySQL database settings unter Plesk nur Serverfehler 500. Mehr Details konnte ich da nicht sehen.

Deshalb habe ich das bei mir lokal mal mit XAMPP (PHP 8.1.2) gestestet. Da kommt der Fehler aber auch.

Mich wundert, warum bei Punkt 3. MySQL database settings die Fehlermeldung Table 'worlds.phpwcms_user' doesn't exist kommt? Die Tabellen werden doch erst zu einem späteren Zeitpunkt angelegt.
Hier die ganze Fehlermeldung aus dem XAMPP Logs:

Code: Select all

==> logs/php_error_log <==
[22-Feb-2022 17:47:38 Europe/Berlin] PHP Fatal error:  Uncaught mysqli_sql_exception: Table 'worlds.phpwcms_user' doesn't exist in /opt/lampp/htdocs/phpwcms/setup/inc/setup.check.inc.php:101
Stack trace:
#0 /opt/lampp/htdocs/phpwcms/setup/inc/setup.check.inc.php(101): mysqli_query(Object(mysqli), 'SELECT * FROM p...')
#1 /opt/lampp/htdocs/phpwcms/setup/setup.php(30): require_once('/opt/lampp/htdo...')
#2 {main}
  thrown in /opt/lampp/htdocs/phpwcms/setup/inc/setup.check.inc.php on line 101

==> logs/access_log <==
::1 - - [22/Feb/2022:17:47:38 +0100] "POST /phpwcms/setup/setup.php?step=1 HTTP/1.1" 500 -
Ein Testsetup in Plesk unter PHP 8.0.15 funktioniert.
Da ich im Forum und Github dazu nichts finden konnte. Muss für 8.1 noch etwas angepasst werden?

Re: Setup unter PHP 8.1.2 bricht bei Datenbank Einstellungen ab

Posted: Wed 23. Feb 2022, 14:46
by Oliver Georgi
Bitte Issues immer im GitHub hinterlegen.

Gibt mögliche Probleme unter PHP 8.1+ in Verbindung mit MySQL 5.7+
https://github.com/slackero/phpwcms/com ... 3711c97656

Re: Setup unter PHP 8.1.2 bricht bei Datenbank Einstellungen ab

Posted: Wed 23. Feb 2022, 18:24
by dani
Oliver Georgi wrote: Wed 23. Feb 2022, 14:46 Bitte Issues immer im GitHub hinterlegen.
Wird beim nächsten Mal gemacht.

Mit Version phpwcms 1.9.33-dev (2022/02/23, r553) läuft das Setup unter PHP 8.1.2 jetzt wieder ohne Fehler.

Danke für die schnelle Anpassung!