PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Hier bekommst Du deutschsprachigen Support. Keine Fehlermeldungen oder Erweiterungswünsche bitte!
Post Reply
Huong II
Posts: 4
Joined: Tue 4. Jun 2019, 09:49

PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by Huong II »

Die Beschreibung unter dem CP Dateiliste für (PDF-)Blockfenster sieht wie folgt aus
Beschreibung | Dateiname | Dateititel | Link Ziel | BxHxC (wenn Bild) | Copyright ↵ …

Mit der Konfiguration wie Beschreibung|||_blank funktioniert es nicht, ein weiteres Fenster für die PDF zu öffnen. :(
Kann mir jemand weiterhelfen?

User avatar
Uwe367
Posts: 1076
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by Uwe367 »

Das sieht nach einem Bug aus.
Erstell doch mal ein Issue bei Github.
Scheint im übrigen nicht der einzige CP zu sein bei dem nicht mehr richtig funktioniert.

User avatar
kukki
Posts: 1674
Joined: Mon 7. Feb 2005, 20:02
Location: Berlin Köpenick
Contact:

Re: PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by kukki »

Kann jemand diese Reaktion bestätigen? :roll:
Aus früheren Versionen kannte ich das Problem auch bereits, aber es wurde nie wieder aufgegriffen.
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.9.20-dev
kukki's SpIeLwIeSe V.1.9.12 R550 responsive

User avatar
Oliver Georgi
Site Admin
Posts: 9667
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by Oliver Georgi »

Muss man nur das Template anpassen.

Code: Select all

<a href="[FILE_URL]{FILE_URL}[/FILE_URL][FILE_URL_ELSE]{FILE_LINK}[/FILE_URL_ELSE]"{FILE_TARGET} title="Download &raquo;{FILE_NAME}&laquo;">
Hängt ja gerade daran, ob eine URL auch mit angegeben ist.

Das ist also kein Bug, sondern nur eine Besonderheit.

Der Standard ist auch so, dass alles direkt heruntergeladen wird. Braucht eigentlich kein _blank.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
Uwe367
Posts: 1076
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by Uwe367 »

Gut zu wissen.
Danke für die Erklärung 😊

User avatar
Oliver Georgi
Site Admin
Posts: 9667
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by Oliver Georgi »

Wurde präzisiert und erweitert, bitte testen
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Huong II
Posts: 4
Joined: Tue 4. Jun 2019, 09:49

Re: PDF Linkziel funktioniert nicht richtig (R 1.9.15/18)

Post by Huong II »

target="_blank" funktioniert jetzt beim Download von PDF-Files!

Danke für die Korrektur! 8)

Post Reply