[solved| Update 1.7.2 auf 1.9.15

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

[solved| Update 1.7.2 auf 1.9.15

Post by santscho »

Meine lieben phpwcms-Kollegen

Sechs Jahre lang war ich nicht mehr aktiv. Bin lediglich noch Webmaster einer russischen Kirche und aktualisiere jeden Monat etwas Content.
Jetzt geht es darum, phpwcms auf die neuste Version zu bringen. Aber ... oh Schreck! Ich habe das Meiste schon wieder vergessen.

Ich habe jetzt die Website komplett auf meinen localhost geladen (inkl. MySQL Datenbank). Möchte das "Original" noch so stehen lassen, falls etwas schief läuft. Der russische Hoster unterstützt PHP 7.3 und MySQL 5.7. Demenstprechend habe ich das auf meinem localhost auch so eingestellt. Die 1.9.15. habe ich auch bereits runter geladen.

Jetzt die peinliche Frage: Es gab mal einen Link, da wurde der Update-Prozess beschrieben. Könnt ihr mir auf die Sprünge helfen? Ich denke, wenn ich mal "drinn" bin, werden meine Erinnerungslücken wieder gefüllt (hoffentlich).

Grüsse
Ralph
Last edited by santscho on Sat 11. Apr 2020, 19:25, edited 3 times in total.
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
Uwe367
Posts: 1076
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Update 1.7.2 auf 1.9.15

Post by Uwe367 »

Hallo Ralph,
Das hier beschreibt meine Vorgehensweise und bisher hatte ich damit noch nie Probleme.
viewtopic.php?f=17&t=25852&p=150047&hil ... te#p150046

Ansonsten mußt du mal im Wiki rein schauen. Knut hatte da mal eine Anleitung verfasst.
https://wiki.phpwcms.org/doku.php/deuts ... ion/update

BTW.. Die neueste Version ist 1.9.16
https://github.com/slackero/phpwcms/releases

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Update 1.7.2 auf 1.9.15

Post by santscho »

Perfekt! Vielen Dank, Uwe!
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Update 1.7.2 auf 1.9.15

Post by santscho »

Setup generiert nur ein Teil der Tabellen. Einige werden nicht erstellt (werden rot angezeigt). Das Problem hatte ich noch nie. :roll:
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
Oliver Georgi
Site Admin
Posts: 9667
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Update 1.7.2 auf 1.9.15

Post by Oliver Georgi »

Schwer zu sagen, versuchst Du es mit einer frischen Installation? Dachte Du wolltest ein Update machen.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
Uwe367
Posts: 1076
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Update 1.7.2 auf 1.9.15

Post by Uwe367 »

Hallo Ralph.
Arbeitest du mit XAMPP auf dem Localhost?
Dann könntest du das gleiche Problem haben was ich mal hatte.
viewtopic.php?f=17&t=25853

Strict Mode in phpmyadmin in der DB deaktivieren und dann sollte es laufen.

Prüfen ob STRICT MODE aktiviert ist:

Code: Select all

SHOW VARIABLES LIKE 'sql_mode';
STRICT MODE deaktivieren:

Code: Select all

set global sql_mode='';
STRICT MODE aktiveren

Code: Select all

set global sql_mode='STRICT_TRANS_TABLES';
Mit aktivem STRICT MODE kommt es bei mir bei einer Neuinstallation unter XAMPP beim Befüllen de DB zu den von dir geschilderten Problem.
Auf dem Live Server bei all-inkl klappt das allerdings wie gewohnt.

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Update 1.7.2 auf 1.9.15

Post by santscho »

Eigentlich möchte ich nur das senden von Formularen wieder zum Laufen bringen (viewtopic.php?f=16&t=25819). Die von Oliver oben beschriebene Methode funktioniert nicht (auswechseln von general.inc.php resultiert in einem nicht funktionierenden Backend).

Darum habe ich entschlossen, das gesamte System auf den neusten Stand zu bringen. Weil der russische Hoster nur 1 MySQL-Datenbank erlaubt, und ich zur Zeit keinen eigenen Host online zur Verfügung habe um eine Upgrade-Sandbox aufzubauen, wollte ich eine phpwcms-Sandbox auf meinem localhost:8888 (MAMP) einrichten.

Methode Standard-Upgrade funktioniert nicht. Hat zuerst nach der Konfigurationsdatei gefragt. Habe die alte aus 1.7.2. dann nach inlcude/config geschoben. Passiert aber gar nichts. Nur weisser Screen.

Werde jetzt mal den Strict-Mode-Tip von Uwe ausprobieren (Neuinstallation)
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Update 1.7.2 auf 1.9.15

Post by santscho »

Bin jetzt einen Schritt weiter.

1. STRICT MODE erfolgreich auf meinem localhost deaktivert (danke Uwe! Habe zwar MAMP, aber das Problem war das gleiche)
2. phpwcms 1.9.16 erfolgreich installiert
3. DB von 1.7.2. in phpmyadmin zusätzlich importiert

Kann ich jetzt in der neuen config einfach auf die Zugangsdaten der alten DB eingeben, oder benötigt die alte DB auch ein Update?
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
Uwe367
Posts: 1076
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Update 1.7.2 auf 1.9.15

Post by Uwe367 »

santscho wrote:
Sun 5. Apr 2020, 16:36
Kann ich jetzt in der neuen config einfach auf die Zugangsdaten der alten DB eingeben, oder benötigt die alte DB auch ein Update?
Ich machs so daß ich in die NEUE conf.inc.php die Zugangsdaten zu der alten (kopierten) DB eingebe. Dann Verzeichnis content/tmp leeren (die checked.tmp Dateien löschen) und das BE aufrufen. DIe Automatik des Systems macht nun das DB Update und die Seite sollte laufen.
Auf diese Weise habe ich schon etliche Seiten auf den neuesten Stand gebracht.

User avatar
Oliver Georgi
Site Admin
Posts: 9667
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Update 1.7.2 auf 1.9.15

Post by Oliver Georgi »

santscho wrote:
Sun 5. Apr 2020, 14:09
auswechseln von general.inc.php resultiert in einem nicht funktionierenden Backend
Achtung! Das habe ich nicht geschrieben, natürlich schlägt es fehl, die gesamte Datei zu tauschen. Es geht genau um die von mir verlinkten Codeabschnitte/Funktionen. Mehr nicht.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Update 1.7.2 auf 1.9.15

Post by santscho »

Oliver Georgi wrote:
Sun 5. Apr 2020, 18:51
santscho wrote:
Sun 5. Apr 2020, 14:09
auswechseln von general.inc.php resultiert in einem nicht funktionierenden Backend
Achtung! Das habe ich nicht geschrieben, natürlich schlägt es fehl, die gesamte Datei zu tauschen. Es geht genau um die von mir verlinkten Codeabschnitte/Funktionen. Mehr nicht.
Wie peinlich. Werde das nochmals probieren. Diesmal richtig.
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: [solved] Update 1.7.2 auf 1.9.15

Post by santscho »

Herzlichen Dank für eure Hilfe! Langsam kommt mein altes Wissen wieder zurück.

Habe die gesamte Website auf meinem localhost auf phpwcms 1.9.16 portiert. Läuft alles wunderbar. Jetzt nur noch Backup von DB und Webfiles und dann GoLive mit der neuen Version.

Fühlt sich gut an, wieder zuhause zu sein :D
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
Uwe367
Posts: 1076
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: [solved] Update 1.7.2 auf 1.9.15

Post by Uwe367 »

Ist doch super.
Hat das mit der neuen Installation und der alten DB geklappt? Würde mich mal interessieren ob das nicht nur bei mir funktioniert...

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: [solved] Update 1.7.2 auf 1.9.15

Post by santscho »

Ja, hat alles so geklappt. Habs genau so gemacht wie Du es beschrieben hast. :-)
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

User avatar
santscho
Posts: 1429
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Update 1.7.2 auf 1.9.15

Post by santscho »

Arbeite schon ein paar Tage mit der neuen Version. Irgend etwas ist wohl beim Update schief gelaufen :shock:

[SOLVED. .htaccess überprüft] 1. Keine Thumbnails im Backend:
Image

[SOLVED. Neuste PHP und MySQL aktiviert)] 2. Kein Zugriff auf den Dateimanager ( {STATUS_MESSAGE}{BE_PARSE_LANG} ):
Image
(habe diesbezüglich im Forum recherchiert. Da gibt es zum einen die These, dass das Update nicht richtig gemacht wurde)

[SOLVED. Neuste PHP und MySQL aktiviert)] 3. Datei-Manager verursacht Rausschmiss:
Image

Auf meinem localhost habe ich diese Probleme nicht.
Last edited by santscho on Sat 11. Apr 2020, 19:04, edited 2 times in total.
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org

Post Reply