Page 1 of 2

problem with login.php, do not have access to php.ini

Posted: Thu 15. Apr 2004, 21:24
by shane
I have downloaded, unpacked, uploaded and ran the setup.php without error with all green lights, however when I try to login I recieve this error:

Fatal error: session_start(): Failed to initialize storage module. in /hsphere/local/home/ssmith/s2studio.org/login.php on line 24

I am hosting through ixwebhosting and do not believe I have access to my php.ini, is there a work around for this?

best,
s

this is my conf.ini.php

<?

// database values
$phpwcms["db_host"] = "69.49.230.13";
$phpwcms["db_user"] = "ssmith_user";
$phpwcms["db_pass"] = "*****";
$phpwcms["db_table"] = "ssmith_data";
$phpwcms["db_prepend"] = "";
$phpwcms["db_pers"] = 0;

// site values
$phpwcms["site"] = "http://s2studio.org/";
$phpwcms["admin_email"] = "shane@s2studio.org";

// paths
$phpwcms["root"] = ""; //default: ""
$phpwcms["file_path"] = "phpwcms_filestorage"; //default: "phpwcms_filestorage"
$phpwcms["file_tmp"] = "phpwcms_tmp"; //default: "phpwcms_tmp"
$phpwcms["templates"] = "phpwcms_template"; //default: "phpwcms_template"
$phpwcms["dir_thlist"] = "thumb_list"; //default: "thumb_list"
$phpwcms["dir_preview"] = "thumb_preview"; //default: "thumb_preview"
$phpwcms["content_path"] = "content"; //default: "content"
$phpwcms["cimage_path"] = "images"; //default: "images"
$phpwcms["ftp_path"] = "phpwcms_ftp"; //default: "phpwcms_ftp"

// content values
$phpwcms["file_maxsize"] = 2097152; //Bytes (50 x 1024 x 1024)
$phpwcms["content_width"] = 538; //max width of the article content column - important for rendering multi column images
$phpwcms["img_list_width"] = 100; //max with of the list thumbnail image
$phpwcms["img_list_height"] = 75; //max height of the list thumbnail image
$phpwcms["img_prev_width"] = 538; //max width of the large preview image
$phpwcms["img_prev_height"] = 400; //max height of the large preview image
$phpwcms["max_time"] = 1800000; //logout after max_time/60 seconds

// other stuff
$phpwcms["compress_page"] = 0; //0 = OFF, 1-9: page compression ON (1 = low level, 9 = highest level)

// debugging timer
$phpwcms["timer"] = 0; //is for displaying a how long it needs to create

$phpwcms["imagick"] = 0; //0 = GD, 1 = ImageMagick convert
$phpwcms["imagick_path"] = ""; //Path to ImageMagick (default="" - none)
$phpwcms["use_gd2"] = 1; //0 = GD1, 1 = GD2
$phpwcms["rewrite_url"] = 0; //whether URL should be rewritable
$phpwcms["wysiwyg_editor"] = 3; //0 = no wysiwyg editor, 1 = HTMLarea, 2 = FCKeditor, 3 = browser based
$phpwcms["phpmyadmin"] = 1; //enable/disable phpMyAdmin in Backend
$phpwcms["default_lang"] = "en"; //default language
$phpwcms["charset"] = "iso-8859-1"; //default charset 'iso-8859-1'

// dynamic ssl encryption engine
$phpwcms["site_ssl_mode"] = '0'; // tuns the SSL Support of WCMS on(1) or off (0) DEFAULT '0'
$phpwcms["site_ssl_url"] = ''; //URL assigned to the SSL Certificate. DON'T add a slash at the End! Exp. "https://www.yourdomainhere.tld"
$phpwcms["site_ssl_port"] = '443'; //The Port on which you SSL Service serve the secure Sites. Servers DEFAULT is '443'

// smtp values
$phpwcms['SMTP_FROM_EMAIL'] = 'shane@s2studio.org'; // reply/from email address
$phpwcms['SMTP_FROM_NAME'] = 'shane'; // reply/from name
$phpwcms['SMTP_HOST'] = 'mail.s2studio.org'; // SMTP server (host/IP)
$phpwcms['SMTP_PORT'] = 25; // SMTP-Server port (default 25)
$phpwcms['SMTP_MAILER'] = 'smtp'; // default phpMailer: smtp, mail (default), sendmail
$phpwcms['SMTP_AUTH'] = 1; // sets SMTP_AUTH to ON/OFF
$phpwcms['SMTP_USER'] = 'shane@s2studio.org'; // default SMTP login (user) name
$phpwcms['SMTP_PASS'] = '****'; // default SMTP password


?>

Posted: Thu 15. Apr 2004, 21:28
by pSouper
can you not use..

Code: Select all

$phpwcms["db_host"] ='localhost' 
?
also check your broswer is allowing cookies too. (beat you IonRock ;) )
also you chmods are in accordance wit th e phpwcms.de > installation details

Posted: Thu 15. Apr 2004, 21:28
by frold
I guess it is this line:

$phpwcms["db_host"] = "69.49.230.13";

Im sure it need to be localhost I do not think you can use the ip address

Posted: Thu 15. Apr 2004, 21:28
by frold
to slow frold... go to bed....

Posted: Thu 15. Apr 2004, 21:30
by pSouper
I beat you to Frold ;)
(and i have more post too :roll: )

thank you with a question

Posted: Thu 15. Apr 2004, 21:38
by shane
Wow this is the fastest forum I have seen.
I will try the suggestion, before I was using Drupal and I needed to insert the actual IP address of the mySQL server since it is running on a different machine then where my site is running. I am not a code guru, but a lowly architecture major, however I was under the impression that the use of localhost was if I was running it off my linux box at home, is this true?

thanks again

s

Posted: Thu 15. Apr 2004, 21:43
by shane
I have changed to local host and have checked all my chmods as far as I can tell and ensured that mozilla is accepting all cookies, still not working. Any other suggestions would be wonderful.

Posted: Thu 15. Apr 2004, 21:50
by pSouper
is your domain name ok without www. ? http://s2studio.org/
if i go to the domain http://s2studio.org/login.php iget...

Code: Select all

Fatal error: session_start(): Failed to initialize storage module. in /hsphere/local/home/ssmith/s2studio.org/login.php on line 24
this looks like your php host has session issues (i'm no expert on this)

Re: thank you with a question

Posted: Thu 15. Apr 2004, 21:53
by frold
shane wrote: I needed to insert the actual IP address of the mySQL server since it is running on a different machine then where my site is running.
Then it is not "localhost" then you have to find the name of the server like "mysql.server.com"

I do not know if you can use the ip address - but if you can find the http address it would be great....

not sure

Posted: Thu 15. Apr 2004, 21:55
by shane
I am not sure who they have their php configured. s2studio.org will work without the www. I modified my conf.ini.php to reflect a post in another forum reply and now have this

Parse error: parse error, expecting `'('' in /hsphere/local/home/ssmith/s2studio.org/include/inc_conf/conf.inc.php on line 51

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /hsphere/local/home/ssmith/s2studio.org/include/inc_lib/default.inc.php on line 27
Error while trying to connect to

is this anycloser to getting it up and running? thanks again for helping me out so much

Posted: Thu 15. Apr 2004, 21:55
by pSouper
when i go here... []urlhttp://www.s2studio.org/index.php[/url] i get further erros for you to investigate.. try....

http://www.phpwcms.de/forum/viewtopic.p ... t&start=15
try creatin this sessiontest.php as described her eby OG. if this doesn't work either the the problem is probably with your host

mysql.ixwebhosting.com

Posted: Thu 15. Apr 2004, 21:56
by shane
frold, yes i have changed it to reflex the http addy shown in my control panel

Re: not sure

Posted: Thu 15. Apr 2004, 21:58
by frold
shane wrote:
Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /hsphere/local/home/ssmith/s2studio.org/include/inc_lib/default.inc.php on line 27
Error while trying to connect to
It is because of the wrong path to the database....

Posted: Thu 15. Apr 2004, 22:00
by frold
I have talked with Oliver you CAN use this path as database path

$phpwcms["db_host"] = "69.49.230.13";

I was wrong :oops:

prob isp

Posted: Thu 15. Apr 2004, 22:04
by shane
I have tried this session test and I believe it may be the ISP, i have had problems with them in the past and will be tranfering. Hopefully next one will have what I need. Thank again for your help.

Best,
s