Cannot use images in FCKEditor

Get help with installation and running phpwcms here. Please do not post bug reports or feature requests here.
Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Cannot use images in FCKEditor

Post by Nik2004 » Sat 28. Apr 2007, 22:45

I am using version 1.3.0 (upgraded from 1.1RC4).

On article edit, when I click the icon "Insert/Edit Picture" (on FCKeditor toolbar - I am using phpwcms_default) I get the popup dialog showing a root folder ("/"). No images are in there.

When I click the down arrow, nothing happens.

When I try to create a folder I get the message "Unknown error creating folder".

When I try to upload a file, no errors are shown, but the file is obviously not uploaded and, as a result, I cannot use it.

I have a folder /picture/upload/Image which is writable (777) but I don't know if this is the real image root directory. Which should it be?

So I can do nothing with images in the article. Any help will be appreciated.

Also, strangely enough, in FILE section, when in Private tab, greek folder names appear with wrong (unreadable) characters, while when in Public tab, the same greek folder names appear with correct characters. I guess some codepage setting should be wrong there. Any suggestion?

User avatar
pico
Posts: 2595
Joined: Wed 28. Jul 2004, 18:04
Location: Frankfurt/M Germany
Contact:

Post by pico » Sun 29. Apr 2007, 11:13

Hi

in new FCKeditor you have to rename the Folders Image -> image (Lowercase) - same to flash - media and file
Lieber Gott gib mir Geduld - ABER BEEIL DICH
Horst - find me at Musiker-Board

Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Post by Nik2004 » Sun 29. Apr 2007, 17:22

I changed to lower case but it's the same. It behaves as before. Nothing works. To make sure: what's the whole path of the directories you describe?

Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Post by Nik2004 » Fri 4. May 2007, 23:56

Now I am using 1.3.3 (upgraded from initially 1.1RC4). When editing an article with fckeditor, I can now upload an image (by clicking the image icon, then going to Upload tab) and the uploaded image gets displayed in the article.

However, I cannot manage images on the server. I checked through FTP and found that the image I upload goes to <rootfolder>/picture/upload. But when I use fckeditor's Image Properties icon and click "Browse Server" I get the following screen, which shows nothing and all buttons do not work.

Image

When I try to upload some file, no message appears, but the file is not uploaded. When I try to create a folder, I give the name and I get the message: "Unknown error creating folder". The "resource type" dropdown has no other entries except "Image" and the folder icon does nothing when clicked.

Note, that in the older version of phpwcms the images I uploaded (and managed without problems) using fckeditor (in article edit), were uploaded at <rootfolder>/content/images.

I guess there should be some config setting regarding fckeditor upload directory. I would like to have <rootfolder>/content/images directory be again the image upload directory for fckeditor and the "browse server" be corrected so that I can reuse the large number of accummulated images already uploaded there.

Any help will be appreciated. I can't find a solution.

User avatar
pico
Posts: 2595
Joined: Wed 28. Jul 2004, 18:04
Location: Frankfurt/M Germany
Contact:

Post by pico » Sat 5. May 2007, 12:43

Hi

FCK in phpwcms uses this Folder(s)
../picture/upload/image
../picture/upload/flash
../picture/upload/media
../picture/upload/file
Lieber Gott gib mir Geduld - ABER BEEIL DICH
Horst - find me at Musiker-Board

User avatar
flip-flop
Moderator
Posts: 8178
Joined: Sat 21. May 2005, 21:25
Location: HAMM (Germany)
Contact:

Post by flip-flop » Sat 5. May 2007, 13:02

And don´t use the upload button at the top.
Please go to image info -> search server.
At this place you can create new folders and you have a running upload button.

Knut
>> HowTo | DOCU | FAQ | TEMPLATES/DOCS << ( SITE )

User avatar
update
Moderator
Posts: 6390
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Sat 5. May 2007, 13:38

Perhaps you would want to check http://www.phpwcms.de/forum/viewtopic.php?t=14661 additionally too :oops:
claus

Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Post by Nik2004 » Sat 5. May 2007, 14:56

Thanks for your replies

flip-flop, this is exactly what I am doing - see my description. I doesn't work.

pico, as I mentioned, the image was uploaded to /picture/upload and not to /picture/upload/image, although this dir exists and has 777 rights.

I tried to use the shell and do what claus did (just in case fckeditor starts to work), but my shell (shared hosting) does not support find and wc commands.

In any case, where do these settings (where images are uploaded, etc.) are stored? Can I change them at will? As I said, I would like to use /content/images directory, because I already have a large no. of images there, and many phpwcms articles are using them. I cannot possibly change all those references, nor is it productive to start using a new image store now...

So, I am still without solution

User avatar
update
Moderator
Posts: 6390
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Sat 5. May 2007, 16:09

but my shell (shared hosting) does not support find and wc commands.
If you open these (all) .js files of fckeditor and switch to hex display you will see "ef bb bf" = "" (without quotation marks, of course) at the very beginning. Just delete "ef bb bf" (lot of files :shock: ) and you will have sorted out some more irritations.

Example:

Code: Select all

ef bb bf 2f 2a 0d 0a 20 2a 20 46 43 4b 65 64 69 
74 6f 72 20 2d 20 54 68 65 20 74 65 78 74 20 65 
64 69 74 6f 72 20 66 6f 72 20 49 6e 74 65 72 6e 
65 74 20 2d 20 68 74 74 70 3a 2f 2f 77 77 77 2e 
66 63 6b 65 64 69 74 6f 72 2e 6e 65 74 0d 0a 20
I would like to use /content/images directory
Isn't there the possibility to edit

Code: Select all

/home/www/user/html/include/inc_ext/fckeditor/editor/filemanager/browser/default/connectors/php/config.php
$Config['UserFilesPath'] = $baseFolder.'/picture/upload/' ;
and

Code: Select all

/home/www/user/html/include/inc_ext/fckeditor/editor/filemanager/upload/php/config.php
$Config['UserFilesPath'] = $baseFolder.'/picture/upload/' ;
or however your paths look like - to get there where you want to?
Just an idea...

claus

Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Post by Nik2004 » Sat 5. May 2007, 18:25

Thanks Claus,

By manipulating the settings in the files you specify (the two config.php files) I managed to now upload to the dir I wanted. The fckeditor image browser still does not operate, but I will try to do the changes in the .js files you mention, and I'll see (I have asked my host to give me access to the shell commands you describe).

User avatar
update
Moderator
Posts: 6390
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Sat 5. May 2007, 18:39

Don't forget to cd into the dir /whatever/andso-on/webroot/eventually-subfolder-for-wcms/include/inc_ext/fckeditor before doing so!! I hope OG will forgive me (the next release will be cleaned up anyway...)
claus

Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Post by Nik2004 » Mon 7. May 2007, 15:32

I now have access to these commands (I mean those in your thread http://www.phpwcms.de/forum/viewtopic.php?t=14661), and I have tried it.

Unfortunately, I cannot copy these special characters into the shell (I use PUTTY, and when I copy, these special chars are omitted), so I had to modify your unix commands.

So the first one becomes:

Code: Select all

grep $'\xEF\xBB\xBF' * -ri | wc -l
I managed to do the above, although it is hard for me to use these commands. The output is 230 (files). So, there is a problem!

Now, claus, I would like your help (you seem to know what you are doing with unix) to rewrite the second command:

Code: Select all

find . -type f -exec sed -i 's///' {} \;
...so that it does NOT contain special chararcters but rather their HEX equivalent (EF BB BF). I checked sed documentation but it's too complex for me.

Thanks in advance.

Nik2004
Posts: 132
Joined: Mon 9. Aug 2004, 14:31
Location: Athens,Greece

Post by Nik2004 » Tue 15. May 2007, 00:39

I found the command (it was not that difficult):

Code: Select all

find . -type f -exec sed -i 's/\xEF\xBB\xBF//' {} \;
This removed the strange characters you mentioned (as in your case). However, in my case, the problems were NOT solved. The fckeditor's Image Properties / Search Server window continues to NOT operate and I don't see any pictures there. I still cannot find out why this does not work. Why I can't browse my server?

User avatar
update
Moderator
Posts: 6390
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Tue 15. May 2007, 02:14

super! :lol:
did you try to empty your cache?

User avatar
DeXXus
Posts: 2168
Joined: Fri 28. Nov 2003, 06:20
Location: USA - Florida

Post by DeXXus » Tue 15. May 2007, 04:20

Nik2004 wrote:However, in my case, the problems were NOT solved. The fckeditor's Image Properties / Search Server window continues to NOT operate and I don't see any pictures there. I still cannot find out why this does not work. Why I can't browse my server?
It ~looks~ like the script's file browser was NOT written to be an "intelligent" general file browser (of any server), BUT rather as one that can be "targeted" at specific file types and folder locations.

Maybe you could try your luck at a "hack" ?
Some of the discussion here may allow you to experiment:

http://fckeditor.biz/viewtopic.php?p=1300#1300

Post Reply