Alt-Attribut bei Teaser/Artikellink

Bitte alle templatebezogenen Beiträge in diesem Forum veröffentlichen.
Post Reply
User avatar
top
Posts: 535
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Alt-Attribut bei Teaser/Artikellink

Post by top »

Ich habe ein individuelles Template für Teaser/Artikellink erstellt und binde dort das jeweilige Artikelbild per [IMAGE]{IMAGE}[/IMAGE] ein.

Leider wird dabei der bei dem Bild (in der Dateizentrale) hinterlegte "Alternativer Text" nicht im Alt-Attribut übernommen und statt dessen der Dateiname dort eingefügt.

Habe ich irgendwas übersehen oder kann ich die Bilder anders einbinden?

Ach ja, als Versionsnummer wird mir 1.9.36-dev angezeigt.
User avatar
Oliver Georgi
Site Admin
Posts: 9886
Joined: Fri 3. Oct 2003, 22:22
Contact:

Re: Alt-Attribut bei Teaser/Artikellink

Post by Oliver Georgi »

Vermutlich übergibst Du eine Bildunterschrift mit dem Content Part. Die muss leer sein, damit die Infos aus der Dateizentrale gezogen werden.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
User avatar
top
Posts: 535
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: Alt-Attribut bei Teaser/Artikellink

Post by top »

Bei den Basisinformationen der Artikeln ist nichts bei den Bildbeschreibungen eingesetzt. Ich übernehme lediglich den Title des entsprechenden Artikels und nutze die Schlüsselwörter um den Teasern verschiedene Klassen zuzuweisen. (Wie hier beschrieben viewtopic.php?p=145788 )

Die Template-Datei ist recht übersichtlich:

Code: Select all

<!--TEASER_HEAD_START//-->[TITLE]
<h3>{TITLE}</h3>
[/TITLE][SUBTITLE]<h4>{SUBTITLE}</h4>
[/SUBTITLE][TEASER]    <div class="teaserbox">
<!--TEASER_HEAD_END//-->

<!--TEASER_ENTRY_START//-->      <a href="{ARTICLELINK}" class="teaserlink col-{COLUMN} row-{ROW}[PRIO] prio-{PRIO}[/PRIO][CLASS] {CLASS}[/CLASS]">[IMAGE]{IMAGE}[/IMAGE]<span>[TITLE]{TITLE}[/TITLE]</span></a><!--TEASER_ENTRY_END//-->

<!--TEASER_ENTRY_SPACER_START//--><!--TEASER_ENTRY_SPACER_END//-->

<!--TEASER_ROW_SPACER_START//--><!--TEASER_ROW_SPACER_END//-->

<!--TEASER_FOOTER_START//-->[/TEASER]
    </div>
<!--TEASER_FOOTER_END//-->

<!--TEASER_COLUMN_OVERWRITE_START//--><!--TEASER_COLUMN_OVERWRITE_END//-->
kmstario
Posts: 396
Joined: Thu 27. Jul 2006, 11:34
Location: Berlin
Contact:

Re: Alt-Attribut bei Teaser/Artikellink

Post by kmstario »

Hallöchen,

also ich setze die Images in den Templates meist selbst zusammen:

Bsp (Bootstrap 4.1.3):

Code: Select all

<!--TEASER_ENTRY_START//-->
			<div class="[ATTR_CLASS]{ATTR_CLASS}[/ATTR_CLASS]">
				<div class="card-content">

				  <div class="card-img">
[ARTICLELINK]<a href="{ARTICLELINK}"[ARTICLELINK_TARGET]{ARTICLELINK_TARGET}[/ARTICLELINK_TARGET]>[/ARTICLELINK]					  
			  	[IMAGE]<img src="{THUMB_REL}" class="img-responsive" alt="{THUMB_NAME}" />[/IMAGE]
			  	
[ARTICLELINK]</a>[/ARTICLELINK]
				  </div>
[ARTICLELINK]<a class="" href="{ARTICLELINK}"[ARTICLELINK_TARGET]{ARTICLELINK_TARGET}[/ARTICLELINK_TARGET]>[/ARTICLELINK]
				  	<div class="card-desc text-center">
    
	    [MENUTITLE]<h4 class="py-3 px-0">{MENUTITLE}
	</h4>[/MENUTITLE]
	
	[MENUTITLE_ELSE]<h4 class="py-3 px-0">[ARTICLELINK]<a class="" href="{ARTICLELINK}"[ARTICLELINK_TARGET]{ARTICLELINK_TARGET}[/ARTICLELINK_TARGET]>[/ARTICLELINK]
		{TITLE}			
	[ARTICLELINK]</a>[/ARTICLELINK]</h4>[/MENUTITLE_ELSE]	

  					</div>
  					[ARTICLELINK]</a>[/ARTICLELINK]
	    		</div>
			</div>

<!--TEASER_ENTRY_END//-->
Vielleicht hilfts ja jemanden,

VG Andreas
--------------------------------------------

Alles Gelingen hat sein Geheimnis, alles Mißlingen seine Gründe.
PHPWCMS ist einfach nur großartig!
Post Reply