banner ads module linking problem

Get help with installation and running official modules for phpwcms here. Please do not post bug reports or feature requests here.
User avatar
lady_witchcraft
Posts: 94
Joined: Sun 14. Nov 2004, 19:19
Location: Austria
Contact:

Re: banner ads module linking problem

Post by lady_witchcraft » Fri 30. Jul 2010, 02:11

thanks oliver, for the link, but the flash contains the clicktag already :?

problem stays the same, no function, no link behind the nice banner ...

greetz & thx for possible support in advance,
claudia
... it's not bad luck, it's a bug ...

User avatar
Oliver Georgi
Site Admin
Posts: 9457
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: banner ads module linking problem

Post by Oliver Georgi » Fri 30. Jul 2010, 12:22

maybe there is a nother problem with JavaScript. Cannot say without visiting the domain and see myself.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

User avatar
lady_witchcraft
Posts: 94
Joined: Sun 14. Nov 2004, 19:19
Location: Austria
Contact:

Re: banner ads module linking problem

Post by lady_witchcraft » Fri 30. Jul 2010, 13:07

thx for your support in advance, url is on the way via PM!

greetz, clau
... it's not bad luck, it's a bug ...

User avatar
Oliver Georgi
Site Admin
Posts: 9457
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: banner ads module linking problem

Post by Oliver Georgi » Fri 30. Jul 2010, 15:33

Achte darauf, dass Du keine absolute URL abfängst. Im Beispiel wird auf http: geprüft. Das gibt es aber nicht.

So müsste es gehen:

Code: Select all

on (release) {
  if (_root.clickTag.substr(0,9) == "index.php") {
    getURL(_root.clickTag, _root.clickTarget==undefined ? "_blank" : _root.clickTarget);
  }
}
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

User avatar
lady_witchcraft
Posts: 94
Joined: Sun 14. Nov 2004, 19:19
Location: Austria
Contact:

Re: banner ads module linking problem

Post by lady_witchcraft » Fri 30. Jul 2010, 17:46

you're my heeeeerroooooooo :oops:

thx a lot oliver, now the script within the banner works fine!
mysterious thing! :roll:

wish you a relaxing weekend, and I doubt this was
the last question I had this weekend :-)

greetz & many thanks,
claudia
... it's not bad luck, it's a bug ...

User avatar
Oliver Georgi
Site Admin
Posts: 9457
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: banner ads module linking problem

Post by Oliver Georgi » Sat 31. Jul 2010, 08:35

OK, to make it perfect we do a general test against clickTag Var:

Code: Select all

if(_root.clickTag != undefined) {
  on (release) {
    // only needed if you want to allow relative links (of your own site) only 
    // if (_root.clickTag.substr(0,9) == "index.php") {
    getURL(_root.clickTag, _root.clickTarget==undefined ? "_blank" : _root.clickTarget);
   // }
  }
}
Then nothing should happen if the clickTag var is not defined.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

caramello
Posts: 70
Joined: Thu 23. Sep 2004, 21:43

Re: banner ads module linking problem

Post by caramello » Wed 23. Jan 2013, 15:01

Ola,

I have running, r528, linking images doesnt work with mod-rewrite enabled.

http://www.uvw.nl

Any clues?
A website is a concept not a digital brochure ! Vectrus Internet Solution

User avatar
Oliver Georgi
Site Admin
Posts: 9457
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: banner ads module linking problem

Post by Oliver Georgi » Sun 27. Jan 2013, 08:22

Hard to follow what you mean. Create issue which describes better, screenshot, source code sample etc.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Post Reply