Installing on IIS on Windows Server 2003

Please post all install related problems here. Visit this forum first for troubleshooting.
Post Reply
PunkassJBrewster
Posts: 8
Joined: Sun 4. Jan 2004, 02:00

Installing on IIS on Windows Server 2003

Post by PunkassJBrewster » Thu 29. Jan 2004, 16:44

Has anyone installed phpWCMS on IIS 6 running on Windows Server 2003?

I am asking because the script I have (setup.php) cannot write to the config.inc.php file. When I click open the downloaded file, it has none of the data I typed. Further, the admin account (webmaster:admin) is not created in MySQL. The tables are created, but no data is inserted. (I do see the country data that is included in the SQL file.)

I am guessing I have my server permissions wrong? PHP, Perl, ImageMagick, and MySQL are all installed and running properly.

This website is run separate from the default website (running two domains, the default is not running phpWCMS.) i am not sure how to set file permissions. Maybe someone has a list of the users and permission the default website needs to have, so I can copy it to the second website?

Thanks again!

Jay.

PunkassJBrewster
Posts: 8
Joined: Sun 4. Jan 2004, 02:00

Post by PunkassJBrewster » Thu 29. Jan 2004, 17:41

I managed to manually add the administrator account by manually runing the following SQL command using MySQL Control Center:

Code: Select all

INSERT INTO phpwcms_user (usr_login, usr_pass, usr_email, usr_admin, usr_aktiv, usr_name ) 
VALUES ("webmaster", PASSWORD('some_pass'),"webmaster@mydomain.com", 1, 1, "phpwcms webmaster");
Now, however, after I log in, I taken to "phpwcms.php" and it is a blank page, with just this html code:

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1"></HEAD>
<BODY></BODY></HTML>
I am guessing my webserver isn't able to write to files, maybe not able to execute or read(?)


Jay.

PunkassJBrewster
Posts: 8
Joined: Sun 4. Jan 2004, 02:00

Post by PunkassJBrewster » Thu 29. Jan 2004, 20:44

I changed the file permissions to the follwoing, as per the installation instructions:

Code: Select all

1) DIR   phpwcms_tmp/thumb_list                    777
2) DIR   phpwcms_tmp/thumb_preview                 777
3) DIR   phpwcms_ftp                               766
4) DIR   phpwcms_filestorage                       777
5) DIR   content/images                            777

6) FILE  setup/setup.conf.inc.php                  666
7) FILE  phpwcms_template/inc_css/frontend.css     666
8) FILE  include/inc_conf/conf.pagelayout.inc.php  666
All files and directories with a 777 UNIX permission I set to read/write/execute to the IUSR_ (internet guest account) user.

All files with the the 766 or 666 UNIX permissions I set to read/write to the IUSR_ (internet guest account) user.

I also made the entire contents of the phpWCMS files and directories to read/write to the IUSR_ (internet guest account) user.

I can log in in the login.php and the left panel whos the "wembaster" account as logged in.

I cannot exit the login.php loop, meaning I keep being returned to the log in page. I cannot view the phpwcms.php page nor the indes.php page.

Any help?

Jay

User avatar
DeXXus
Posts: 2168
Joined: Fri 28. Nov 2003, 06:20
Location: USA - Florida

Post by DeXXus » Thu 29. Jan 2004, 21:46


User avatar
Oliver Georgi
Site Admin
Posts: 9560
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Post by Oliver Georgi » Fri 30. Jan 2004, 00:21

Have you checked the setup.cof.ic.php in setup folder?
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

PunkassJBrewster
Posts: 8
Joined: Sun 4. Jan 2004, 02:00

Post by PunkassJBrewster » Fri 30. Jan 2004, 23:04

I've tried all you suggested. Nothing seems to work. I am stuck in an endless loop where I am taken back to loging.php

User avatar
Oliver Georgi
Site Admin
Posts: 9560
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Post by Oliver Georgi » Fri 30. Jan 2004, 23:13

if no user is created you can not login. You can create the user manually: use phpMyAdmin. You can create the user manually:

Code: Select all

INSERT INTO phpwcms_user (usr_login, usr_pass, usr_email, usr_admin, usr_aktiv, usr_name ) VALUES ('webmaster', PASSWORD('admin'), 'my@email.com', 1, 1, 'phpwcms webmaster');
If you use a db prefix use "...INTO PREFIX_phpwcms_user (..."

Oliver
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

PunkassJBrewster
Posts: 8
Joined: Sun 4. Jan 2004, 02:00

SOLVED! It was a session issue.

Post by PunkassJBrewster » Sat 31. Jan 2004, 21:19

I have solved it!!!

Anyone who experiences similar problems - getting stuck in the log-in loop take note! It affects all webservers on Windows.

The culprit: The session directory needs to be set in your php.ini file!

Solution: Some of the users running phpWCMS on Windows server platform are still unable to login. This sometimes depends on wrong settings of the temporary session path in php.ini.

If you run phpWCMS on Windows please check your php.ini file for session_save_path.

By default it may be set to session_save_path="/tmp" which is not valid for a Windows installation.

Set it to session_save_path="c:/php/temp/" or whatever you decide your temp path to be.

VOILA!


Thanks again for the suggestions!


Jay.

Caroline
Posts: 5
Joined: Fri 11. Jun 2010, 23:39

Re: Installing on IIS on Windows Server 2003

Post by Caroline » Sat 12. Jun 2010, 14:35

Hi everyone, I'm new here and have recently started using phpwcms.

I've found this topic as it seems to relate to my problem, I'm getting stuck at the log-in screen and can't get any further. I have time this weekend only to create a new page for my website and I've lost half the time already (this has been going on since last night).

I can see your fix - above, but I'm not any kind of web developer and I really don't understand the language that's been used - I'd be sooooo grateful if someone would be able to run through it with me, step by step - so I can get on the admin site again.

Thank you loads

Caroline :o)

Post Reply