What you should do first if you have problems!!!

Please post all install related problems here. Visit this forum first for troubleshooting.
Locked
User avatar
Oliver Georgi
Site Admin
Posts: 9560
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

What you should do first if you have problems!!!

Post by Oliver Georgi » Tue 25. Nov 2003, 16:46

  1. check your PHP Version - recommend > 4.3.0
  2. is safe_mode on -> recommend safe_mode Off
  3. register_globals should be set OFF
  4. check permissions -> try to set every folder/file to 777 if problems still exists
  5. proof your path settings in conf.inc.php -> and if you post error messages related to file not found, permissions and so in - post the content of your conf.inc.php WITHOUT username/passwords
  6. have you downloaded most current version of phpwcms
  7. check your GD-version if no ImageMagick installed: GD1 produces bad results.
  8. Please post good description and what you have done or not
  9. Post in English or German.
  10. Do not Email me - try the forum first!
  11. I don't know
Oliver
Last edited by Oliver Georgi on Thu 8. Mar 2007, 00:30, edited 5 times in total.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Florian
Posts: 119
Joined: Wed 19. Nov 2003, 16:50
Location: Hamburg
Contact:

Post by Florian » Tue 25. Nov 2003, 22:59

  • 12. Allways post your php.log / webserver.log OR/AND the failure Message on a support request
    13. Post which Webserver and OS you are running
    14. Use the forum search to see, if there's allready a workaround existing for your problem
So you could help yourself maybe faster than we can here in the forum :D

Cheers,
Florian

User avatar
Oliver Georgi
Site Admin
Posts: 9560
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Post by Oliver Georgi » Sat 3. Jan 2004, 22:06

If you have PHP's SAFE_MODE ON and you cannot change to Off then you have to create the user specific file folders manually.

Inside phpwcms_filestorage create as many directories like you have users. Each dir has to be named like user's ID: the ID is only an integer beginning with Number 1 and so on...

The problem is: when you create a dir in php safe_mode on it will get user wwwrun - but you do not have permissions for user wwwrun ;-)

Oliver
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

colech
Posts: 178
Joined: Thu 25. Mar 2004, 01:01
Location: Washington, USA
Contact:

Post by colech » Thu 25. Mar 2004, 20:56

  • 15. Be aware that PHP >= 5 does not support MySQL by default as earlier versions did. Reason.

Hans van Meteren
Posts: 4
Joined: Sat 26. Jun 2004, 20:57

Re: What you should do first if you have problems!!!

Post by Hans van Meteren » Sat 26. Jun 2004, 21:03

Oliver Georgi wrote:
  1. check your PHP Version - recommend > 4.3.0
  2. New!!! session.use_trans_sid set On otherwise you will not have a chance to login.

    Oliver
Hi Oliver,
the comment in my standard php.ini (powweb) reads:

; trans sid support is disabled by default.
; Use of trans sid may risk your users security.
; Use this option with caution.
; - User may send URL contains active session ID
; to other person via. email/irc/etc.
; - URL that contains active session ID may be stored
; in publically accessible computer.
; - User may access your site with the same session ID
; always using URL stored in browser's history or bookmarks.
session.use_trans_sid = 0

What now? And if it not a problem, should I set it to 1?

Thanks, Hans

User avatar
Oliver Georgi
Site Admin
Posts: 9560
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Post by Oliver Georgi » Sat 26. Jun 2004, 21:11

No - as I could test over the last weeks there is no need to set session.use_trans_sid On. You can try if you have problems with session register or login or something like that.

Oliver
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Locked