Loosing images in text w/image article

Please post all install related problems here. Visit this forum first for troubleshooting.
Post Reply
trixs
Posts: 6
Joined: Fri 17. Jul 2015, 11:36

Loosing images in text w/image article

Post by trixs » Fri 17. Jul 2015, 11:51

Dear collegues,
I'm very newbie with phpwcms, and don't have a lot of experience with it.
I created prototype of website on local server (Win8+XAMPP) and it worked well.
Then I moved it to hosting with the same version of phpwcms. During installation everything was OK (and green in last grid).
I imported the database, changed conf.ini as I need, moved changed templates (news, imagetext.tmpl, include/inc_front/front.func.inc.php) and the scripts for changing language support from template/inc_scripts/frontend_init and frontend_render. Then I moved images from filearchive and /template/img.
I got quite working site in web but I found some problem: pictures, which is inserted in text using CKeditor is not shown neither in CKeditor nor in result rendered page. In filebrowser it's shown, google show errors:
Failed to load resource: the server responded with a status of 404 (Not Found) http://new.mcsplus.ru/img/cmsimage.php/ ... 6cec67.png Failed to load resource: the server responded with a status of 404 (Not Found) http://new.mcsplus.ru/img/cmsimage.php/ ... 6cec67.png
In the same time pictures attached through the articles' editor interface under CKeditor shows well.

I tried different versions of PHP (5.4 and 5.5) on hosting with the same result.
Unfortanetly I could not find any solution, so I need to ask here, thank you.

You can find the example page in web here: http://new.mcsplus.ru/index.php?ru/radarviewer

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Loosing images in text w/image article

Post by update » Fri 17. Jul 2015, 13:16

Did you transfer the content folder and it's subfolders?
What did you do with include/inc_front/front.func.inc.php???
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

trixs
Posts: 6
Joined: Fri 17. Jul 2015, 11:36

Re: Loosing images in text w/image article

Post by trixs » Fri 17. Jul 2015, 17:30

My content folder has files except index.html only in image and tmp subfolders. As I read content folder should be filled after first access to image or something like that, so files in it will be recreated.
In include/inc_front/front.func.inc.php I have changed buildingCascadingMenu function, because for my design I need few <div> with some parameters inside of <li> for rotating text back to vertical.
Actually I have found the problem already, it's "slash" against "question mark" problem, http://forum.phpwcms.org/viewtopic.php?f=1&t=24739&e=0. Anyway thank you for a feedback.

Post Reply