PHP version 5.3.x ??

Please post all install related problems here. Visit this forum first for troubleshooting.
Post Reply
eralf
Posts: 67
Joined: Tue 11. Oct 2005, 19:12

PHP version 5.3.x ??

Post by eralf » Thu 21. Apr 2011, 10:51

I want on my server upgrade the PHP to version 5.3.6.
On the webserver I run 50 sites with phpwcms.
PHPwcms version 1.3.3 to the latest version 1.4.7.
Can I expect problems or can phpwcms unproblematically use PHP 5.3.6.?

User avatar
Oliver Georgi
Site Admin
Posts: 9478
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: PHP version 5.3.x ??

Post by Oliver Georgi » Thu 12. May 2011, 04:04

It runs without any problems but check types of error reporting before doing so. It will produces some warnings and notices about deprecated things. Also be warned that some refernces $foo =& $whatever can make problems — so check your php.ini to be setup to deal with it.

Try with an older install first locally before sending everything to hell.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Post Reply