v1.9.0-beta.4 with MySQLi support needs testing!

Read me first before posting anywhere!
User avatar
Oliver Georgi
Site Admin
Posts: 9387
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

v1.9.0-beta.4 with MySQLi support needs testing!

Postby Oliver Georgi » Wed 16. Nov 2016, 18:36

Hey guys,

I have committed a new branch v1.9-dev to GitHub. This will be the development basis of the forthcoming version of phpwcms.

I need your help! Because this branch got massive changes it is necessary that you test it very careful. It is really not for productional use at the moment.

Download 1.9 development release

It's just the first step. All native PHP MySQL functions (these are deprecated and not PHP7 compatible) were replaced by phpwcms’ own database functions (simple DBAL, based on MySQLi). You should check your custom scripts too and replace native mysql functions by _dbQuery() or special DB functions like _dbGet(), _dbUpdate(), _dbInsert().

Please! Report any issue – from installation to the backend and the frontend. Send in detailed error messages.

Cheers,
Oliver
Last edited by Oliver Georgi on Wed 16. Nov 2016, 18:38, edited 1 time in total.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn

Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest