Falsche Darstellung bei CP Artikel mit weiter Link

Bitte alle templatebezogenen Beiträge in diesem Forum veröffentlichen.
rbstuttgart
Posts: 45
Joined: Sun 13. Jul 2008, 10:45

Falsche Darstellung bei CP Artikel mit weiter Link

Post by rbstuttgart »

Liebes Forum,

wo steckt den die Formatierung für den CP Artikel? Bei der Funktion "[Weiter…] Link" mit Teasertext werden automatisch am Textende drei Punkte erzeugt ... Diese schließen direkt am Text an. Dies ist aber orthografisch falsch. Es muss ein Freiraum dazwischen sein.

Besten Dank aus Stuttgart

rbstuttgart
User avatar
update
Moderator
Posts: 6446
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by update »

Wenn nicht direkt im entsprechenden CP-Template, dann eventuell in der conf.template_default.inc.php in /config/phpwcms/
It's mostly all about maintaining two or three customer's sites Still supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.
Now building a venue for young artists to get wet on stage, rehearsal rooms, a studio, a guitar shop - yes I'm going to build some guitars.
rbstuttgart
Posts: 45
Joined: Sun 13. Jul 2008, 10:45

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by rbstuttgart »

Bin irgendwie zu doof. Weder im CP-Template (articlesummary/list) oder in "conf.template_default.inc.php" habe ich die drei Punkte gefunden.
User avatar
update
Moderator
Posts: 6446
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by update »

»

nee nee, see next one
It's mostly all about maintaining two or three customer's sites Still supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.
Now building a venue for young artists to get wet on stage, rehearsal rooms, a studio, a guitar shop - yes I'm going to build some guitars.
User avatar
update
Moderator
Posts: 6446
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by update »

It's mostly all about maintaining two or three customer's sites Still supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.
Now building a venue for young artists to get wet on stage, rehearsal rooms, a studio, a guitar shop - yes I'm going to build some guitars.
rbstuttgart
Posts: 45
Joined: Sun 13. Jul 2008, 10:45

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by rbstuttgart »

Super lieben Dank. Nun hats der Doofe auch kapiert. Sollte man aber grundsätzlich ändern.
photojo
Posts: 710
Joined: Wed 15. Nov 2006, 20:02
Location: Regensburg, Germany
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by photojo »

Sollte das das hier sein?

Code: Select all

$template_default['top_readmore_link']		= 'more…';
Da ändert sich bei mir im FE leider nichts?!

Gruß
Jo
User avatar
kukki
Posts: 1692
Joined: Mon 7. Feb 2005, 20:02
Location: Berlin Köpenick
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by kukki »

da kann man auch ein Bild "reinhämmern", ist schon die richtige Stelle:

Code: Select all

$template_default['top_readmore_link']      = '{IMAGE:weiter.png}';
bei

Code: Select all

$phpwcms['enable_deprecated'] = true;
oder halt mit img-Tag selber ausschreiben, je nach Einstellung in der config.inc.php.

Wenn an dieser Stelle etwas nicht stimmt, dann mal mit IE ansehen, da müßte dann der "blöde" Platzhalter zu sehen sein!
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.9.20-dev
kukki's SpIeLwIeSe V.1.9.12 R550 responsive
photojo
Posts: 710
Joined: Wed 15. Nov 2006, 20:02
Location: Regensburg, Germany
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by photojo »

Danke!
Ich probier das mal!
photojo
Posts: 710
Joined: Wed 15. Nov 2006, 20:02
Location: Regensburg, Germany
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by photojo »

Ich kriege einfach keinen Leerschritt nach dem letzten Wort und den drei Punkten hin?!
User avatar
update
Moderator
Posts: 6446
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by update »

Wie probierst Du es denn jetzt genau?
It's mostly all about maintaining two or three customer's sites Still supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.
Now building a venue for young artists to get wet on stage, rehearsal rooms, a studio, a guitar shop - yes I'm going to build some guitars.
User avatar
kukki
Posts: 1692
Joined: Mon 7. Feb 2005, 20:02
Location: Berlin Köpenick
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by kukki »

linuxluder wrote:Ich kriege einfach keinen Leerschritt nach dem letzten Wort und den drei Punkten hin?!
Leerschritt ... wat'n dat :?: Ein Leerzeichen mit " " oder so ?

Geht aber auch mit CSS margin/ padding - so wie Du es brauchst!

Image

Ungarantiert geht es auch mit Einstellungen bei "top_readmore_before" ... ich bevorzuge aber CSS!
claus wrote:Wie probierst Du es denn jetzt genau?
zeig mal was dazu (URL) :idea:
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.9.20-dev
kukki's SpIeLwIeSe V.1.9.12 R550 responsive
User avatar
Oliver Georgi
Site Admin
Posts: 9792
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by Oliver Georgi »

Linkimage ist sooooo 1995.

Code: Select all

<a href="#" class="read-more">Weiterlesen…</a>

a.read-more {
    display: inline-block;
    width: 100px;
    line-height: 25px;
    text-indent: -999em;
    background: url(mylink-image.png) no-repeat 0 0;
    text-decoration: none;
}
a.read-more:hover {
    background-position: 0 -40px;
    text-decoration: none;
}
Und es kann durchaus sein, dass der Template Default nicht mehr greift. Da ich nicht weiß wo genau das jetzt nicht geht, mal schauen in template/template_lang/de.php ob es da auftaucht.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
photojo
Posts: 710
Joined: Wed 15. Nov 2006, 20:02
Location: Regensburg, Germany
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by photojo »

Sorry, wenn ich mich falsch ausgedrückt habe.
Ein Häkchen bei "[Weiter…] Link " bewirkt, dass nach beim dem letzten Wort des Schlagtextes sofort "..." kommt.
Also "Meine Schlagtext zeigt hier..." statt "Meine Schlagtext zeigt hier ...", also kein Leerzeichen nach dem letzten Wort.
User avatar
Oliver Georgi
Site Admin
Posts: 9792
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Falsche Darstellung bei CP Artikel mit weiter Link

Post by Oliver Georgi »

Welchen Content Part meinst Du denn nun genau.

Mach mal Screenshot.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
Post Reply