Page 1 of 1

Flash Support

Posted: Thu 3. Dec 2020, 15:02
by Oliver Georgi
What do you think? Should I remove Flash support completely from phpwcms?
The reason: by the end of 2020 nearly all browsers will no longer support Flash.

Re: Flash Support

Posted: Thu 3. Dec 2020, 18:18
by Uwe367
Flash is deprecated and, how you write, it will only take a short time and no modern Browser will support it longer. There are so much other solutions avaiable than flash. I say... remove it or at this time, in case of older Websites which are using flash in connection with phpwcms, set a "depecated" switch in conf.inc.php. in case of system updates. So the Admin can decide by itself what he want to do.
But in future Versions, maybe 2.0 if it is then sometime available :wink: , kick it out.

That´s my opinion to this.

Re: Flash Support

Posted: Fri 4. Dec 2020, 12:31
by nameless1
Remove Flash
Implement BT4 BE instead :D

Re: Flash Support

Posted: Fri 4. Dec 2020, 14:41
by Oliver Georgi
nameless1 wrote: Fri 4. Dec 2020, 12:31 Implement BT4 BE instead :D
BT5

Re: Flash Support

Posted: Sun 20. Dec 2020, 18:13
by dani
Will there maybe a security issue when we stay at BT 3.x ( EOL 2019-07-24 - https://github.com/twbs/release ) until BT 5.x is implemented?

Re: Flash Support

Posted: Sun 20. Dec 2020, 18:58
by Oliver Georgi
dani wrote: Sun 20. Dec 2020, 18:13 Will there maybe a security issue when we stay at BT 3.x ( EOL 2019-07-24 - https://github.com/twbs/release ) until BT 5.x is implemented?
As far I see there are no security issues. It's mostly a question of supported browsers and platforms. Bootstrap 3.x still works very well and is stable. It just lacks modern features like Flexbox.