Can´t save the shop settings

Get help with installation and running official modules for phpwcms here. Please do not post bug reports or feature requests here.
Post Reply
kai32a

Can´t save the shop settings

Post by kai32a » Wed 21. Nov 2007, 10:23

I´ve got the same problem as ZELSIUS.

a) phpWCMS Version 1.3.5.1 fresh installed
b) config.inc.php settings

Code: Select all

$phpwcms['SESSION_FEinit']    = 1; // set 1 to enable sessions in frontend, 0 to disable sessions in frontend 
$phpwcms['Login_IPcheck']    = 0; 
c) shop setup deleted
d) MySQL updated, Table phpwcms_sysvalue deleted and new installed

Code: Select all

CREATE TABLE `phpwcms_sysvalue` ( 
`sysvalue_key` varchar(255) NOT NULL default '', 
`sysvalue_group` varchar(255) NOT NULL default '', 
`sysvalue_lastchange` int(11) NOT NULL default '0', 
`sysvalue_status` int(1) NOT NULL default '0', 
`sysvalue_vartype` varchar(100) NOT NULL default '', 
`sysvalue_value` text NOT NULL, 
PRIMARY KEY (`sysvalue_key`), 
KEY `sysvalue_group` (`sysvalue_group`), 
KEY `sysvalue_status` (`sysvalue_status`) 
) 
I can add CATEGORIES, i can add PRODUCTS but i can´t save the settings (Tax, Payment...). When i click the "SAVE-Button" the formular will be blank again.

The very basic shop runs under

Sorry for my bad english and i hope there is someone who kann help me...

Thanks from the blackforest
Last edited by kai32a on Wed 17. Feb 2010, 11:01, edited 1 time in total.

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Wed 21. Nov 2007, 10:29


User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Wed 21. Nov 2007, 10:45


kai32a

Post by kai32a » Wed 21. Nov 2007, 12:06

this should be under following tread:

http://www.phpwcms.de/forum/viewtopic.php?t=15803

sorrry

Hello Admin can you move this?

kai32a

deleted all shop shop tables

Post by kai32a » Wed 21. Nov 2007, 12:17

now i have deleted all shop tables and created them new:

Code: Select all

CREATE TABLE `phpwcms_categories` (
  `cat_id` int(10) unsigned NOT NULL auto_increment,
  `cat_type` varchar(255) NOT NULL default '',
  `cat_status` int(1) NOT NULL default '0',
  `cat_createdate` datetime NOT NULL default '0000-00-00 00:00:00',
  `cat_changedate` datetime NOT NULL default '0000-00-00 00:00:00',
  `cat_name` varchar(255) NOT NULL default '',
  `cat_info` text NOT NULL,
  PRIMARY KEY  (`cat_id`),
  KEY `cat_type` (`cat_type`,`cat_status`)
) ENGINE=MyISAM CHARSET=latin1;


CREATE TABLE `phpwcms_shop_orders` (
  `order_id` int(10) unsigned NOT NULL auto_increment,
  `order_number` varchar(20) NOT NULL default '',
  `order_date` datetime NOT NULL default '0000-00-00 00:00:00',
  `order_name` varchar(255) NOT NULL default '',
  `order_firstname` varchar(255) NOT NULL default '',
  `order_email` varchar(255) NOT NULL default '',
  `order_net` float NOT NULL default '0',
  `order_gross` float NOT NULL default '0',
  `order_payment` varchar(255) NOT NULL default '',
  `order_data` mediumtext NOT NULL,
  `order_status` varchar(100) NOT NULL default '',
  PRIMARY KEY  (`order_id`),
  KEY `order_number` (`order_number`,`order_status`)
) ENGINE=MyISAM CHARSET=latin1;


CREATE TABLE `phpwcms_shop_products` (
  `shopprod_id` int(10) unsigned NOT NULL auto_increment,
  `shopprod_createdate` datetime NOT NULL default '0000-00-00 00:00:00',
  `shopprod_changedate` datetime NOT NULL default '0000-00-00 00:00:00',
  `shopprod_status` int(1) unsigned NOT NULL default '0',
  `shopprod_uid` int(10) unsigned NOT NULL default '0',
  `shopprod_ordernumber` varchar(255) NOT NULL default '',
  `shopprod_model` varchar(255) NOT NULL default '',
  `shopprod_name1` varchar(255) NOT NULL default '',
  `shopprod_name2` varchar(255) NOT NULL default '',
  `shopprod_tag` varchar(255) NOT NULL default '',
  `shopprod_vat` float unsigned NOT NULL default '0',
  `shopprod_netgross` int(1) unsigned NOT NULL default '0',
  `shopprod_price` float NOT NULL default '0',
  `shopprod_maxrebate` float NOT NULL default '0',
  `shopprod_description0` text NOT NULL,
  `shopprod_description1` text NOT NULL,
  `shopprod_description2` text NOT NULL,
  `shopprod_description3` text NOT NULL,
  `shopprod_var` mediumtext NOT NULL,
  `shopprod_category` varchar(255) NOT NULL default '',
  `shopprod_weight` float NOT NULL default '0',
  `shopprod_color` varchar(255) NOT NULL default '',
  `shopprod_size` varchar(255) NOT NULL default '',
  `shopprod_listall` int(1) unsigned NOT NULL default '0',
  PRIMARY KEY  (`shopprod_id`),
  KEY `shopprod_status` (`shopprod_status`),
  KEY `category` (`shopprod_category`),
  KEY `tag` (`shopprod_tag`),
  KEY `all` (`shopprod_listall`)
) ENGINE=MyISAM CHARSET=latin1;

CREATE TABLE `phpwcms_sysvalue` (
  `sysvalue_key` varchar(255) NOT NULL default '',
  `sysvalue_group` varchar(255) NOT NULL default '',
  `sysvalue_lastchange` int(11) NOT NULL default '0',
  `sysvalue_status` int(1) NOT NULL default '0',
  `sysvalue_vartype` varchar(100) NOT NULL default '',
  `sysvalue_value` text NOT NULL,
  PRIMARY KEY  (`sysvalue_key`),
  KEY `sysvalue_group` (`sysvalue_group`),
  KEY `sysvalue_status` (`sysvalue_status`)
) ENGINE=MyISAM CHARSET=latin1;

ALTER TABLE `phpwcms_categories` ADD `cat_pid` INT( 11 ) NOT NULL AFTER `cat_type` ; 
ALTER TABLE `phpwcms_categories` ADD INDEX ( `cat_pid` ) ; 

But i can´t save the shop settings!

Hope someone can help me.

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Wed 21. Nov 2007, 12:32

Do you have TABLE `phpwcms_log` ? Perhaps ... hmmm :?

kai32a

TABLE `phpwcms_log`

Post by kai32a » Wed 21. Nov 2007, 17:36

Hello Claus,

sorry for my bad english... german should be better :D

The TABLE `phpwcms_log` exists.

http://www.gehring-cms.de/picture/forum/mySQL.gif

I have deleted the TABLE `phpwcms_log` and fresh installed, but in the shop modul I can´t save the settings.

Code: Select all

#####################################################
#
#  PHPWCMS SQL Update
#  
#  Upgrade release 1.3.5 to 1.3.5.1
#
#####################################################


ALTER TABLE `phpwcms_categories` ADD `cat_pid` INT( 11 ) NOT NULL AFTER `cat_type` ;
ALTER TABLE `phpwcms_categories` ADD INDEX ( `cat_pid` ) ;

CREATE TABLE `phpwcms_log` (
  `log_id` int(11) NOT NULL auto_increment,
  `log_type` varchar(255) NOT NULL,
  `log_timestamp` timestamp NOT NULL,
  `log_message` text NOT NULL,
  `log_ip` varchar(50) NOT NULL,
  `log_userid` varchar(255) NOT NULL,
  PRIMARY KEY  (`log_id`)
) TYPE=MyISAM ;

ALTER TABLE `phpwcms_guestbook` CHANGE `guestbook_created` `guestbook_created` INT(11) NOT NULL ;
ALTER TABLE `phpwcms_userlog` CHANGE `logged_change` `logged_change` INT(11) DEFAULT '0' NOT NULL ;
ALTER TABLE `phpwcms_userlog` CHANGE `logged_start` `logged_start` INT(11) DEFAULT '0' NOT NULL ;
When I klick the Save-Button, the formular for the settings will be cleared. There is no Warning or Error-Message.

http://www.gehring-cms.de/picture/forum ... lungen.gif
http://www.gehring-cms.de/picture/forum/produkte.gif

I can insert produkts and categories without problems.

Since yesterday I have installed the version phpWCMS 1.3.5.1 three or four times... hmmm should I try a other version?

Thanks for helping me... blackforest is greating

smoke
Posts: 53
Joined: Tue 13. Jan 2004, 13:50
Location: Berlin

Post by smoke » Tue 18. Dec 2007, 23:27

the very same here!

I tried everything I could find here and in other threads, but still I can't save the settings.

does someone have a clue why?

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Post by update » Wed 19. Dec 2007, 09:26


User avatar
juergen
Moderator
Posts: 4553
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Post by juergen » Wed 19. Dec 2007, 09:36

Hmmm...

have a look: When you create the shop tables there is already:

Code: Select all

CREATE TABLE `phpwcms_sysvalue` (
  `sysvalue_key` varchar(255) NOT NULL default '',
  `sysvalue_tstamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
  `sysvalue_value` mediumblob NOT NULL,
  PRIMARY KEY  (`sysvalue_key`),
  FULLTEXT KEY `sysvalue_key` (`sysvalue_key`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
which does not come from the shop. Íts inside from normal installation. So ... installing the shop the sysvalue table is left behind without a change.

So what you need is:

Code: Select all

CREATE TABLE `phpwcms_sysvalue` (
  `sysvalue_key` varchar(255) NOT NULL default '',
  `sysvalue_group` varchar(255) NOT NULL default '',
  `sysvalue_lastchange` int(11) NOT NULL default '0',
  `sysvalue_status` int(1) NOT NULL default '0',
  `sysvalue_vartype` varchar(100) NOT NULL default '',
  `sysvalue_value` text NOT NULL,
  PRIMARY KEY  (`sysvalue_key`),
  KEY `sysvalue_group` (`sysvalue_group`),
  KEY `sysvalue_status` (`sysvalue_status`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
In all my installs the sysvalue is emmpty, if so you just flush it an make it new.

That should be all....

Juergen

smoke
Posts: 53
Joined: Tue 13. Jan 2004, 13:50
Location: Berlin

Post by smoke » Wed 19. Dec 2007, 11:39

thank you claus and df6ih,

I tried both! at least 10 times!
but still it wont work :(

I am really helpless.


Image

another strange thing is, that I can not accept payment, because there is nothing to accept:


Image

I am really helpless.

User avatar
NoNameBaby
Posts: 57
Joined: Wed 1. Jun 2005, 23:36
Location: daheim

Re: Can´t save the shop settings

Post by NoNameBaby » Wed 27. Feb 2008, 11:08

@smoke:

Have you solved the problem with the settings? Because I've got the same and desperatly am looking for a solution.

smoke
Posts: 53
Joined: Tue 13. Jan 2004, 13:50
Location: Berlin

Re: Can´t save the shop settings

Post by smoke » Sun 2. Mar 2008, 14:24

nope. still desperate too :(
guess I have to wait untill the new release.

nebenaube
Posts: 139
Joined: Fri 23. Nov 2007, 20:39
Location: Redlands, CA
Contact:

Re: Can´t save the shop settings

Post by nebenaube » Fri 7. Mar 2008, 19:16

I solved this: the system is not naming the tables correctly.
view your database and modify the code to properly match the db_prepend value in your configuration.

see: http://forum.phpwcms.org/viewtopic.php? ... 15#p100515

User avatar
NoNameBaby
Posts: 57
Joined: Wed 1. Jun 2005, 23:36
Location: daheim

Re: Can´t save the shop settings

Post by NoNameBaby » Sat 8. Mar 2008, 16:58

nebenaube wrote:I solved this: the system is not naming the tables correctly.
view your database and modify the code to properly match the db_prepend value in your configuration.

see: http://forum.phpwcms.org/viewtopic.php? ... 15#p100515
No, pittily not.
http://forum.phpwcms.org/viewtopic.php? ... 97#p100566
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Wer ein Problem mit mir hat, kann es gerne behalten - es ist schließlich seins!

Post Reply