Fehler bei Upgrade von 1.3.3 nach 1.9.8

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Mon 20. May 2019, 09:29

Hallo zusammen,
ich habe nach der bekannten Vorlage versucht, die alte Version 1.3.3 auf die aktuelle Version 1.9.8 zu aktualisieren. Nach schrittweiser Ausführung der notwendigen Datenbankupdates (in der Doku bis Version 1.5) ist unter meiner angelegten Subdomain das Frontend sichtbar, aber beim Versuch, mich in domainname/login.php einzuloggen bekomme ich folgende Meldungen:

Warning: mysqli_connect() [function.mysqli-connect]: (HY000/2005): Unknown MySQL server host 'p:mysql5.domain.com' (3) in /kunden/12345678/webseiten/webordner/include/inc_lib/dbcon.inc.php on line 29

Warning: Cannot modify header information - headers already sent by (output started at /kunden/123456789/webseiten/webordner/include/inc_lib/dbcon.inc.php:29) in /kunden/123456789/webseiten/webordner/include/inc_lib/default.inc.php on line 915

Warning: Cannot modify header information - headers already sent by (output started at /kunden/123456789/webseiten/webordner/include/inc_lib/dbcon.inc.php:29) in /kunden/123456789/webseiten/webordner/include/inc_lib/default.inc.php on line 918


Ich sehe schon, dass es sich um Probleme mit der aktualisierten Datenbank handelt, aber ich komme hier nicht weiter. Hat jemand von euch vielleicht Erfahrungen mit einer ähnlichen Situation bzw. irgendeinen Tipp?

Danke und Viele Grüße :?

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Tue 21. May 2019, 12:39

Schlicht falsche Datenbankkonfiguration: Unknown MySQL server host. Prüfe das gegen.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Tue 21. May 2019, 14:00

Bei einer weiteren Installation habe ich ein ähnliches Problem:

Upgrade von Version 1.3.5.4 auf 1.7.5: Nach Ausführung aller Schritte vor "Upgrade existing installation" sehe ich in den letzten Logfiles bei Provider STRATO folgende Meldungen.

21.05.2019 13:35:32 cms.subdomain.de [client XXX] AH012XX: PHP Notice: Undefined index: host in /mnt/web124/e1/95/53563795/htdocs/folder/include/inc_lib/default.inc.php on line 165: /home/strato/http/premium/rid/37/95/12345/htdocs/folder/setup/upgrade.php
21.05.2019 13:35:32 cms.subdomain.de [client XXX] AH012XX: PHP Fatal error: Cannot redeclare dumpVar() (previously declared in /mnt/web124/e1/95/12345/htdocs/folder/include/inc_lib/default.inc.php:450) in /mnt/web124/e1/95/12345/htdocs/include/inc_lib/general.inc.php on line 1056: /home/strato/http/premium/rid/37/95/53563795/htdocs/folder/setup/upgrade.php

Der erste Installationsschritt zeigte keine Probleme:

1. Thanks! You have agreed to the GPL.
Now that you know the licence under which phpwcms is released you can continue to install or upgrade phpwcms.

2. Now lets check your server settings
Please proof all information about your system (recommend PHP 5.3+, MySQL 5.0+).

WWW server: Apache/2.4.39 (Unix)
PHP version: 7.1.28OK
MySQL version: 5.5.52OK
PHP settingsSecurity risks
register_globals OffOK
GD2 bundled (2.1.0 compatible)GD2
Image types supported: GIFGIF supported/ PNGPNG supported/ JPGJPG supported


Zugangsdaten zur Datenbank sind richtig in die conf.inc.php und dist.conf.inc.php eingetragen.

In die neu verknüpfte Datenbank habe ich den exportierten Inhalt der alten Datenbank ohne Probleme importiert.

In Chrome erschein bei Klick auf "Update existing installation" diese Meldung:
Diese Seite funktioniert nicht meinedomain.de kann diese Anfrage momentan nicht verarbeiten.
HTTP ERROR 500


In Firefox bleibt das Fenster einfach leer.

Was kann ich übersehen haben??

Mir fällt jetzt nichts mehr ein – wo kann der Fehler liegen.

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Tue 21. May 2019, 18:19

Welche Version nutzt Du? Für mich scheint da einiges bei Dir durcheinander zu sein. Bitte arbeite mit vollständigen Kopien der cms Installation
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Wed 22. May 2019, 11:32

Hallo,

ich habe Version 1.9.8 nochmal neu installiert, neue Datenbank angelegt (MySQL-Client-Version: 5.1.61 / UTF8), conf.inc.php aus alter Installation importiert, mit dist.conf.inc.php abgeglichen und in beiden die Zugangsdaten für die Datenbank aktualisiert, unter "doc_root" den absoluten Serverpfad angegeben, diverse PHP7-Versionen ausprobiert.

Resultat immer gleich – es kommt diese Meldung und kein weiterer Hinweis:
We are sorry!
For service reasons the system is temporarily not attainable.

Visit us later again!

Es ist echt zum Verzweifeln :oops: :oops: :evil:

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Wed 22. May 2019, 12:11

Also ich habe Installationen bei Strato am Laufen, also der normalen Endkunden-Hostingumgebung. Ich denke Du hast an irgendeiner Stelle eine Konfiguration nicht so, wie diese seitens Strato sein sollte.

Prinzipiell kann ich mir das anschauen, brauche Zugangsdaten. Ist das ein Fehler in phpwcms geht es aufs Haus, liegt der Fehler bei Dir, erwarte ich etwas Kompensation.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Mon 27. May 2019, 12:19

Hallo Oliver, danke für deine Tipps. Mir ist es in der Zwischenzeit gelungen, nach einigen Komplikationen und notwendigen Anpassungen auf Version 1.8.0 upzugraden (meine Versuche auf 1.9.8 zu aktualisieren waren ab dem Versuch auf "upgrade.php" zuzugreifen beendet).

Mit der weitgehend korrekt funktionierenden Version 1.8.0 habe ich aber jetzt noch ein seltsames Problem:

Wenn ich beliebige Artikel aufrufe, sehe ich überall die Content Parts, die auch aufrufbar und ohne Probleme editierbar sind.

Bei einigen Artikeln lässt sich aber die Head-Information, also die "Produktübersicht", nicht mehr aufrufen. Es erscheint ein langer Link im URL-Feld und das Browserfenster bleibt leer. Diese Artikel werden auch im Frontend nicht richtig dargestellt, d.h., es fehlen die Content Parts. Kann es sein, dass sich bei der schrittweisen Aktualisierung der Datenbank ein paar (vielleicht bekannte) Bugs eingeschlichen haben? Die im Verlasuf der Aktualisierung gemeldeten doppelten Datenbankeinträge habe ich direkt korrigiert. Sonst habe ich nichts hinzugefügt.

Mir war übrigens auch noch aufgefallen, dass die angelegten Vorlagen zwar offenbar aufgelistet waren, aber in einigen davon die Inhalte (der Code) fehlten. Diese hatte ich mir aus der alten Vorlage händisch herüberkopiert.

Sind solche Probleme bekannt? Wie gehe ich am besten vor?

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Mon 27. May 2019, 12:38

Du hast den Charset gewechselt. Das gibt probleme und sollte vermieden werden.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Tue 28. May 2019, 00:06

Ich habe das so verstanden, das neuere Versionen von phpwcms über UTF8 laufen. Was habe ich denn falsch gemacht?

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Tue 28. May 2019, 05:51

einen bestehenden Charset kannst Du nicht einfach umschalten, die Konfiguration alter Installationen sollte man diesbezüglich nicht ändern, wenn man nicht versteht, was das nach sich zieht. Du hast daraus keinen echten Vorteil, nur Probleme.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Wed 29. May 2019, 09:37

Dann wäre ich für einen oder zwei Tipps dankbar:

Ich habe das so verstanden, das zunächst die alte Datenbank exportiert wird, was mit aktuellen MySQL-Admin-Versionen nach UTF8 passiert.

Dann lege ich eine neue Datenbank an, wobei zunächst eine Serverversion anzugeben ist ( 3.23.58 oder 5.6.19).
1. Frage: Welche Version muss hier angegeben werden?

Die Anleitung von FlipFlop habe ich so verstanden, dass dann die exportierte, alte Datenbank, die jetzt in UTF8 vorliegt, vor dem Reimport mittels einem Editor wie PSpad nach "ISO Latin 2" konvertiert werden muss, damit auch die neue Datenbank über "ISO Latin" läuft – richtig?

Meine Importversuche nach Serverversion "5.6.19" (in UTF8 und in Latin1) produzierten jedes Mal SQL-Syntaxfehler (z.B. "Timestamp(14)" oder Type = MySAM) schlugen fehl.

Nachdem es irgendwie gelungen war, bei eingeschaltetem "Kompatibilitätsmodus" die Tabellen zu importieren, war anschließend die Anwahl von "upgrade.php" nicht möglich. Und auch eine neue, jungfräuliche Installation der neuesten Version scheiterte sogar.

Ich wäre dir sehr dankbar, wenn du mir an dieser Stelle weiterhelfen könntest, weil ich nach wirklich Tage langer Suche einfach nicht weiterkomme.

Viele Grüße

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Wed 29. May 2019, 09:47

Mir fehlt aktuell die Zeit, Dich zu beraten.

Ich empfehle Dir ein Update lokal. MySQL exportiert zwar als UTF-8, aber die Daten für das Rückspielen sind nicht UTF-8. Im Dump Deiner DB kannst Du z.B. Timestamp(14) einfach ersetzen durch TIMESTAMP. Wenn die neue Datenbank angelegt wurde, diese Umstellen auf Charset Latin1 und latin1_general_ci.

Struktur der alten Tabelle erst anlegen, dann die Daten importieren.

Beim Export mit phpmyAdmin auf den Kompatibilitätsmodus achten.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Wed 29. May 2019, 12:56

Also ich habe nochmal alle Schritte (nach Version 1.9.8 ) genau befolgt und ausgeführt und es sah bis jetzt alles prima aus.

Im Installationsfenster erhalte ich dann bei Klick auf "upgrade" folgende Nachricht:

Parse error: syntax error, unexpected ')' in /kunden/130967_31595/webseiten/webordner/unterverzeichnis/setup/upgrade.php on line 241

Ist das ein Schreibfehler?

User avatar
Oliver Georgi
Site Admin
Posts: 9555
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Oliver Georgi » Wed 29. May 2019, 16:44

Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Miguel
Posts: 190
Joined: Tue 30. Oct 2007, 13:35
Location: Düsseldorf

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Post by Miguel » Wed 5. Jun 2019, 10:21

Hallo,

mittlerweile ist es mir gelungen, eine Version 1.9.8 ans Laufen zu bekommen. Grundsätzlich sieht alles auf den ersten Blick gut aus.

Beim zweiten Blick fällt auf, dass an irgendeiner Stelle beim Reimport der Datenbank etwas nicht richtig eingestellt war, denn in einigen Bereichen (längst nicht allen) werden Umlaute und das "ß" durch ein Fragezeichen ersetzt.

Ich habe bereits angefangen, das – zum Teil durch Suchen und Ersetzen – in der verknüpften Datenbank zu ändern, aber das schein sehr mühsam und aufwändig zu sein.

Deshalb meine Frage: Ist es möglich, den Export und das Upgrade der Datenbank zu wiederholen und dann die Installation über die conf.inc.php mit einer korrigierten Datenbank zu verknüpfen?

Post Reply