Absolut neue Install. und Fehler ?

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
Post Reply
User avatar
kukki
Posts: 1661
Joined: Mon 7. Feb 2005, 20:02
Location: Strausberg bei Berlin
Contact:

Absolut neue Install. und Fehler ?

Post by kukki » Tue 11. Apr 2017, 16:08

Nach einem absolut neuem Setup mit aktuellster Ausgabe (frisch gezogen über git) und klick auf HOME, kommt (immer noch :shock: ) der Fehler:
Parse error: syntax error, unexpected T_FUNCTION in /home/www/webxxx/html/meinCMS/include/inc_module/mod_shop/frontend.render.php on line 1095
Ich brauche aber den Minishop, ansonsten ist durch das Löschen des Verzeichnisses mod_shop der Fehler weg, Umbenennen reicht nicht :(

WARUM, WESHALB, WIESO :?:
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.8.7 Beta R544
kukki's SpIeLwIeSe 1.8.7 Beta R544, responsive

User avatar
Oliver Georgi
Site Admin
Posts: 9475
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: Absolut neue Install. und Fehler ?

Post by Oliver Georgi » Tue 11. Apr 2017, 16:44

wie wärs mal damit, PHP umzustellen? PHP 5.5 bzw. 5.6 empfohlen. Vermutlich arbeitest Du noch mit 5.2.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

User avatar
kukki
Posts: 1661
Joined: Mon 7. Feb 2005, 20:02
Location: Strausberg bei Berlin
Contact:

Re: Absolut neue Install. und Fehler ?

Post by kukki » Tue 11. Apr 2017, 17:35

Nö, alles so eingestellt!

Image
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.8.7 Beta R544
kukki's SpIeLwIeSe 1.8.7 Beta R544, responsive

User avatar
Oliver Georgi
Site Admin
Posts: 9475
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: Absolut neue Install. und Fehler ?

Post by Oliver Georgi » Tue 11. Apr 2017, 18:05

Ich kann keinen Fehler nachvollziehen, nicht in PHP 5.3.29, 5.5.38, 5.6.30…

An der Position wird eine anonyme Funktion definiert.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

User avatar
kukki
Posts: 1661
Joined: Mon 7. Feb 2005, 20:02
Location: Strausberg bei Berlin
Contact:

Re: Absolut neue Install. und Fehler ?

Post by kukki » Tue 11. Apr 2017, 18:09

Und nun? Der Minishop war halt Gegenstand der Homepageerstellung.
Könnte hier ein Fall zu strenger PHP-Restriktionen vorliegen? Kann man das irgenwie überprüfen :?:
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.8.7 Beta R544
kukki's SpIeLwIeSe 1.8.7 Beta R544, responsive

User avatar
Oliver Georgi
Site Admin
Posts: 9475
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: Absolut neue Install. und Fehler ?

Post by Oliver Georgi » Tue 11. Apr 2017, 19:26

kukki wrote:Kann man das irgenwie überprüfen
man kann, kann man
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Old Boy
Posts: 1035
Joined: Fri 23. Nov 2012, 13:52

Re: Absolut neue Install. und Fehler ?

Post by Old Boy » Tue 11. Apr 2017, 22:50

In deiner .htacess hast du keine andere PHP Version aktiviert?

User avatar
kukki
Posts: 1661
Joined: Mon 7. Feb 2005, 20:02
Location: Strausberg bei Berlin
Contact:

Re: Absolut neue Install. und Fehler ?

Post by kukki » Wed 12. Apr 2017, 06:35

Old Boy wrote:In deiner .htacess hast du keine andere PHP Version aktiviert?
Nö, alles Standard, alles sowie wie zuvor über GIT gezogen.
Oliver Georgi wrote:man kann, kann man
Hier hätte ich gerne einen brauchbaren Vorschlag.
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.8.7 Beta R544
kukki's SpIeLwIeSe 1.8.7 Beta R544, responsive

User avatar
Oliver Georgi
Site Admin
Posts: 9475
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: Absolut neue Install. und Fehler ?

Post by Oliver Georgi » Wed 12. Apr 2017, 06:47

kukki wrote:Hier hätte ich gerne einen brauchbaren Vorschlag.
jemanden beauftragen, sich das anzuschauen und eventuell sogar zu lösen
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

User avatar
top
Posts: 440
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: Absolut neue Install. und Fehler ?

Post by top » Wed 12. Apr 2017, 09:31

Welche PHP-Version spuckt dir denn die phpinfo() (im Admin-Menü von phpwcms) aus?

User avatar
kukki
Posts: 1661
Joined: Mon 7. Feb 2005, 20:02
Location: Strausberg bei Berlin
Contact:

Re: Absolut neue Install. und Fehler ?

Post by kukki » Wed 12. Apr 2017, 18:42

PHP 5.5 - so wie es sein soll und oben angegeben.

Nach meinen teilweise mehrstündigen Telefonaten mit dem Provider ist folgendes herausgekommen:

- vor 14 Tagn wurden neue Filter festgelegt, um gegen die Angriffe auf wordgepresste Seiten Ruhe zu finden. Dazu hat man zuvor Tests fahren lassen - nur mich hat keiner befragt. :|
- Jetzt stellte sich heraus, u.a. auch durch meine Meckerei :twisted: :twisted: , dass diese Filter einfach zu streng sind und eine Menge an Fehlerfluten verursachten.
- ich habe jetzt wieder zwei Websites, die normal ohne Fehler funktionieren und den Minishop bedienen.
- es ist also kein Fehler in phpWCMS :!: , sondern gequirlte Providerschei....., die ein äußerst geltungsbedürftiger Systemadmin einführen wollte. :shock:
- einziges Problem ist noch die Fehlermeldung
Parse error: syntax error, unexpected T_FUNCTION in /home/www/webxxx/html/meinCMS/include/inc_module/mod_shop/frontend.render.php on line 1095
wo man(n) noch nach der Ursache forscht, warum auf einigen Server das funktioniert und auf anderen eben nicht.
Lieber arm dran als Arm ab!

meine historische Website: Jagdgeschwader 300 1.8.7 Beta R544
kukki's SpIeLwIeSe 1.8.7 Beta R544, responsive

Post Reply