MySQL Version nicht erkannt bei lokaler XAMPP Installation

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
Post Reply
thoblerone
Posts: 98
Joined: Fri 27. Jan 2006, 23:34
Location: Essen, Germany
Contact:

MySQL Version nicht erkannt bei lokaler XAMPP Installation

Post by thoblerone » Sun 6. Mar 2016, 11:34

Moin,

ich steh grad auf dem Schlauch, und das an einem frostigen Sonntagmorgen :)

Um "mal eben" was auszuprobieren habe ich mir lokal eine frische Xampp-Installation aufgesetzt. Die läuft auch und ich konnte z.B. per mySqlAdmin die Sicherung einer bestehenden phpwcms DB einspielen. Dann habe ich per github mein lokales repository aktualisiert und anschließend dieses Verzeichnis in das xampp htdocs unterverzeichnis phpwcms kopiert.

Da ich lokal und unter Win arbeite, habe ich mich explizit zunächst nicht um die Rechte gekümmert; später per FTP explizit alle Dateien (der Bequemlichkeit halber) auf 777 geändert, aber das ändert weder am Berechtigungsstatus noch am Problem etwas.

Alles ist also lokal am Platz und ich lege los mit der Installation im Browser: http://localhost/phpwcms/. Die erste Seite "I agree the GPL, continue" sieht schon mal gut aus.

Aber dann hakt es auch schon. Beim Überprüfen der Server settings sehe ich
"PHPWCMS SETUP VERSION 1.8.2, RELEASE 2016/02/27

1. Thanks! You have agreed to the GPL. [... bla ...]

2. Now lets check your server settings

Please proof all information about your system (recommend PHP 5.3+, MySQL 5.1+).

WWW server: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.19
PHP version: 5.6.19OK
MySQL version: "

Und an dieser Stelle bricht die Seite ab, auch im Quelltext. Es sieht so aus als käme hier etwas ausser Tritt beim Erkennen der mysql Version. Dazu passiert weder etwas im Apache error log noch im PHP error log. In letztem ergibt sich aber ein Eintrag, wenn ich ein fehlerhaftes php test-script ausführe.

Die Xampp Version ist gerade heruntergeladen: 5.6.19, phpwcms 1.8.2. Vermutlich mache ich irgend etwas einfaches falsch: nur was?

LG
Thomas

User avatar
Oliver Georgi
Site Admin
Posts: 9457
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: MySQL Version nicht erkannt bei lokaler XAMPP Installati

Post by Oliver Georgi » Sun 6. Mar 2016, 14:33

vermutlich unterstützt Xampp nur noch mysqli und pdo, aber nicht mehr die als deprecated gekennzeichnete mysql Erweiterung. Einfach in der php.ini aktivieren. Oder was anderes als Xampp nutzen, z.B. https://www.mamp.info/de/downloads/
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

thoblerone
Posts: 98
Joined: Fri 27. Jan 2006, 23:34
Location: Essen, Germany
Contact:

Re: MySQL Version nicht erkannt bei lokaler XAMPP Installati

Post by thoblerone » Sun 6. Mar 2016, 22:07

Hallo Oliver,

wie gerne bei Dir: auf Anhieb die absolut richtige Antwort, kurz und knapp, vielen Dank!

Und damit ich es selber im Forum bei der nächsten Installation wiederfinde :D der gleiche Handgriff etwas ausführlicher beschrieben:

1. Aus der XAMP Installation die Datei <XAMPP-Ordner>/php/php.ini öffnen
2. Suche "mysql"
3. erster Trefffer, in meiner Version Zeile 889, hier befindet sich die Konfiguration der Windows Extensions. Nach der Grundinstallation steht hier

Code: Select all

;;extension=php_mysql.dll
4. Diese Zeile ändern, die Semikola entfernen

Code: Select all

extension=php_mysql.dll
5. Speichern, dann Apache Modul einmal beenden und neu starten

Fertig. Danke.

Post Reply