[SVN-Version r403] Fehlermeldung nach dem Installieren

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
User avatar
bogus
Posts: 75
Joined: Tue 18. Jan 2005, 17:36

[SVN-Version r403] Fehlermeldung nach dem Installieren

Post by bogus »

Hallo ;D

Ich hab über SVN die Version r403 runtergeladen und installiert, soweit ging alles glatt. Als ich mich einloggen wollte kam diese Meldung

[quote]Warning: require_once(./config/phpwcms/conf.inc.php) [function.require-once]: failed to open stream: No such file or directory in /kunden/xxxx/hosting/dev/phpwcmsdev/login.php on line 29

Fatal error: require_once() [function.require]: Failed opening required './config/phpwcms/conf.inc.php' (include_path='.:/usr/local/lib/php') in /kunden/xxxxx/hosting/dev/phpwcmsdev/login.php on line 29[/quote]

Kann mir da einer weitehelfen ?

Danke in vorraus ;D
Greetings

Bogus
User avatar
flip-flop
Moderator
Posts: 8178
Joined: Sat 21. May 2005, 21:25
Location: HAMM (Germany)
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by flip-flop »

Hi,

die Datei "config/phpwcms/conf.inc.php" existiert?

Knut
>> HowTo | DOCU | FAQ | TEMPLATES/DOCS << ( SITE )
User avatar
bogus
Posts: 75
Joined: Tue 18. Jan 2005, 17:36

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by bogus »

Hi ;)

Jup, die Datei existiert ;D
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by juergen »

Na dann ist es ein Pfad Problem, was immer es hervorruft.
User avatar
bogus
Posts: 75
Joined: Tue 18. Jan 2005, 17:36

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by bogus »

[quote="DF6IH"]Na dann ist es ein Pfad Problem, was immer es hervorruft.[/quote]

Hi ;)

Sowas ähnliches habe ich mir schon gedacht, nur wo steckt da der Fehler ?
User avatar
flip-flop
Moderator
Posts: 8178
Joined: Sat 21. May 2005, 21:25
Location: HAMM (Germany)
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by flip-flop »

Wie sehen denn deine Pfade in der config aus?


Z.B. sähe so eine Installation in einem UnterUnterverzeichnis aus und würde angesprochen mit
http://example.com /xxx/r403/index.php

Code: Select all

$phpwcms['site']              = 'http://'.$_SERVER['SERVER_NAME'].'/';

$phpwcms['root']              = xxx/r403';         //default: ''
Knut
>> HowTo | DOCU | FAQ | TEMPLATES/DOCS << ( SITE )
Reisender69
Posts: 8
Joined: Sat 6. Nov 2010, 19:05

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by Reisender69 »

flip-flop wrote:Hi,

die Datei "config/phpwcms/conf.inc.php" existiert?

Knut
Also bei mir existiert diese Datei nicht :shock: wo bekomme ich die denn her? ich hab nämlich das gleiche Problem dass die Installation abbricht. habe mir die aktuelle Version auch von der Downloadseite geladen.
User avatar
flip-flop
Moderator
Posts: 8178
Joined: Sat 21. May 2005, 21:25
Location: HAMM (Germany)
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by flip-flop »

Docu wrote: Nichts desto trotz klicken Sie jetzt auf "Download the created config file" und speichern Sie die Datei auf Ihrer Festplatte ab. Und laden Sie dann die Datei mit dem FTP Programm in Ordner "config/phpwcms/" hoch.
(Alternativ können SIe auch die Datei /setup/setup.conf.inc.php mit ihrem FTP Programm herunterladen und nach /config/phpwcms/conf.inc.php hochladen).

Löschen Sie dann bitte aus Sicherheitsgründen den kompletten Setup Ordner. Wenn Sie das nicht machen, stellt das ein großes Sicherheitsrisiko dar.
Docu: phpwcms Installationsanleitung -> conf.inc.php erstellen und hochladen

Knut
>> HowTo | DOCU | FAQ | TEMPLATES/DOCS << ( SITE )
Reisender69
Posts: 8
Joined: Sat 6. Nov 2010, 19:05

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by Reisender69 »

flip-flop wrote:
Docu wrote: Nichts desto trotz klicken Sie jetzt auf "Download the created config file" und speichern Sie die Datei auf Ihrer Festplatte ab. Und laden Sie dann die Datei mit dem FTP Programm in Ordner "config/phpwcms/" hoch.
(Alternativ können SIe auch die Datei /setup/setup.conf.inc.php mit ihrem FTP Programm herunterladen und nach /config/phpwcms/conf.inc.php hochladen).

Löschen Sie dann bitte aus Sicherheitsgründen den kompletten Setup Ordner. Wenn Sie das nicht machen, stellt das ein großes Sicherheitsrisiko dar.
Docu: phpwcms Installationsanleitung -> conf.inc.php erstellen und hochladen

Knut
mag ja sein, dass ich blind bin... aber config.inc.php ist ja kein Verzeichnis sondern eine Datei. Oder ist das dahingehend zu verstehen dass man die setup.conf.inc.php in conf.inc.php umbenennen soll und diese dann in /config/phpwcms/hochladen muss, damit die Installation funktioniert?
User avatar
flip-flop
Moderator
Posts: 8178
Joined: Sat 21. May 2005, 21:25
Location: HAMM (Germany)
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by flip-flop »

Exakt (Steht auch während der Installation auf der letzten Seite (dort wo alles grün sein sollte).
>> HowTo | DOCU | FAQ | TEMPLATES/DOCS << ( SITE )
pepe
Posts: 3954
Joined: Mon 19. Jan 2004, 13:46

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by pepe »

Ich hatte schon x mal und seit mehreren Jahren darauf hin gewiesen, dass dieser Textlink im Setupscript für viele NewBees NICHT zu "sehen" ist... hier würde sich ein "Download-Icon" anbieten...

Nicht jeder, der mit phpwcms zu experimentieren beginnt, ist ein Kenner :(
Nicht jeder hat den Blick für das Wesentliche :(

Allerdings hat O.G. hier auch schon mehrfach geschrieben, phpwcms sei nicht für Anfänger gedacht...
und konsequent ist er ja nun mal, unser Oliver, so kennen wir ihn seit Jahren :lol:
User avatar
Heiko H.
Posts: 868
Joined: Thu 27. Oct 2005, 11:41
Location: Dresden
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by Heiko H. »

Pepe,

Du hast völlig recht ABER!!!, wie Knut bereits geschrieben hat
RTFM -> Docu: phpwcms Installationsanleitung -> conf.inc.php erstellen und hochladen

Man kommt nun mal, gerade als Anfänger, nicht drum herum, sich mit einem System eingehend zu beschäftigen, d.h. lesen, lesen, lesen, testen, probieren, weiterlesen,... und dann evtl. mal zu fragen...
Die Erfahrung zeigt, dass so leider kaum einer vorgeht... :? Aber das haben wir hier auch schon erschöpfend erörtert.

Naja, was reg ich mich auf? Ich zieh den Hut vor Euch, die Ihr hier beinahe täglich gebetsmühlenartig die selben Fragen beantwortet.

Ich bin dann mal wieder weg, Heiko...

Nachtrag:
bogus ist hier länger dabei als ich und Knut!!!, soviel zum Newbee... ;)
Not longer here - sorry...

Haubner-IT GbR Dresden
User avatar
top
Posts: 481
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by top »

Ist mir anfangs auch mehrmals passiert. (Die Abstände zwischen den Installationen war einfach zu groß.) Irgendwo in den Weiten des Forums hatte ich sicher auch schon mal (erfolglos) angeregt auf den Download-Link deutlicher hinzuweisen.

Siehe es als Test ob du würdig bist dieses geniale CMS nutzen zu dürfen. Dadurch, dass du hier im Forum um Hilfe gebeten hast, hast du den Test (wenn auch nur knapp) nochmal bestanden. ;)
Reisender69
Posts: 8
Joined: Sat 6. Nov 2010, 19:05

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by Reisender69 »

top wrote:Ist mir anfangs auch mehrmals passiert. (Die Abstände zwischen den Installationen war einfach zu groß.) Irgendwo in den Weiten des Forums hatte ich sicher auch schon mal (erfolglos) angeregt auf den Download-Link deutlicher hinzuweisen.

Siehe es als Test ob du würdig bist dieses geniale CMS nutzen zu dürfen. Dadurch, dass du hier im Forum um Hilfe gebeten hast, hast du den Test (wenn auch nur knapp) nochmal bestanden. ;)

Oh ich verneige mein Haupt als Unwürdiger vor den Gurus dieses Programms /*ironie off

naja, ich dachte mir, da hab ich schon ne Homepage und wollte die ein wenig flüssiger gestalten, hab dann bei meinem Proviver dieses CMS gefunden, da ich als Betreiber einer Ferienhausvermietung diese mittels besagter Homepage flüssiger machen will.

Zur Zeit ist meine Homepage sehr statisch. Hab mir diese mittels Dreamweaver "zusammengebaut". Hab leider auch nicht sooooviel Zeit um da richtig tief einzusteigen. Allerdings wurde mir PHPWcms als recht einfach zu lernend empfohlen. Und nun steh ich da und kann nicht mal das "alte" CMS Version 1.2.3 auf den neuesten Stand bringen, und sowas nervt mich dann doch.
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: [SVN-Version r403] Fehlermeldung nach dem Installieren

Post by juergen »

Und wieso schreibst du nicht zum Beispiel :

Kann mir einer von euch Nullpen mal sowas eben schnell installieren :mrgreen: :lol:

Oder etwas freundlicher und dann melden sich noch andere *grins*
Post Reply