[done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Alle installationsbezogenen Probleme hier posten. Dies sollte die erste Anlaufstelle bei Problemen sein.
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

[done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

Nach einem (meiner Meinung nach) sauberen Upgrade von phpwcms 1.3.9 auf 1.4.0, werden keine Flash-Dateien (.swf) im Frontend ausgegben.

Contentpart Multimedia:
CP geöffnet, Flash-Datei nochmals ausgewählt, gespeichert. ->Bringt nichts
Flash Datei im Filemanager gelöscht, neu hochgeladen, im CP neu ausgewählt. -> Bringt nichts

Auch der Mod "Image Rotator" zeigt anstatt der Bilder nur noch Schwarz und den rotierenden "Lade-Kreis".

:?:

Gruss
Santscho
Last edited by santscho on Thu 25. Dec 2008, 20:46, edited 1 time in total.
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

Zeig doch mal ... lass uns teilhaben am Debakel :mrgreen:
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

http://www.perbi.ch

Auf der Homepage, zwischen dem Artikel und "Druckerfreundliche Ansicht". In diesem Weissraum sollte eine Lokomotive fahren.

Und hier eine Diashow:
http://www.perbi.ch/index.php?konfektion
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

Ha! Komme der Sache näher! Safari zeigt mir folgendes an:
Image

Werde das mal überprüfen.
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

Sag mal, ich habe mit dem Imagerotator lange nichts mehr gemacht, aber war der nicht für IMAGES ?
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

Also die fehlenden XML habe ich hochgeladen. Der image rotator sollte eigentlich wieder funktionieren. Doch jetzt bekomme ich "Verboten" für das Bild, welches im Image rotator geladen werden sollte. filearchive/ hat die Rechte 777. Alle Dateien in Filearchive haben 666.

Komischerweise bekomme ich Fehler 403: Forbidden wenn ich www.perbi.ch/filearchive/ aufrufen möchte (obwohl index.html vorhanden). Werde mal den Hoster anskypen...
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

Ach, das ist der gemütlcih fertig frühstücken Server ? ! :idea: :arrow: :mrgreen:
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

Ich hab grad mal nachgesehen, da ist eine .htaccess drinnen, wenn dein directory listing abgeschlatet ist kannst die ja mal deaktivieren. Vermutungshalber siehst du die nicht, weil Linux das als versteckte Datei handhabt und du root Rechte und ssh brauchst um das Teil zu löschen.
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

Tatsächlich! Wie kommt die denn rein?

Code: Select all

deny from all
gelöscht! Vielen Dank!
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: [done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

Ja, die ist da mal drinnen damit wir unsere Kopfhaut massieren, die grauen Zellen vom fetten Essen befreien (gültig für Europa) und dem Hoster klar machen, dass er sicherstellen soll dass es da keine open Base directorys gibt.
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: [done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

Man müsste mal probieren wenn man die Directive um Folgendes ergänzt:
Wie gehabt:
deny from all

dann:
Allow from 192.168.0
Allow from 127.0.0

um den Effekt auszuschließen. dass selbt der Server ausgesperrt wird, aber das scheint nur bei Apache2 zu funktionieren.
User avatar
juergen
Moderator
Posts: 4554
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: [done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by juergen »

In der Gefahr zum Forenspammer zu werden....

Frag deinen Hoster nochmal ob er sich wirklich sicher ist, den Kasten im Griff zu haben ?
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: [done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

Hat er.
eidg. diplomierter Wirtschaftsinformatiker FH, und Löwenbändiger eines globalen Systems-Engineering-Teams in der Finanzindustrie mit Mitarbeitern in England, Schweiz, USA und Indien. Er hat jahrelange Erfahrung im Aufbauen und Leiten von Online Communities im Open Source Bereich, u.a. als Community-Manager und Webmonkey beim IceWM Window Manager und dem Gtk-Gnutella Gnutella-Client, als Katalysator der Community-Bildung und als Packager bei CRUX Linux, und last but not least als Gründer und Head Monkey der ersten Jahre bei Symlink, dem deutschsprachigen Slashdot.
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
breitsch
Posts: 473
Joined: Sun 6. Mar 2005, 23:12
Location: bern switzerland

Re: [done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by breitsch »

Update des Imagerotator Moduls kommt nächstens, damit kann dann auch die .htaccess im filearchive belassen werden.
Enthält Update auf imagerotator 3.17 und swfobject 2.1 und kommt im Frontend ohne Mootools aus.
Zudem wird eine noscript-option den Flash Player auch ohne Javascript laden.
Im Moment kommt noch eine Option zum Einlesen ganzer Ordner aus der Dateizentrale hinzu.
http://www.youtube.com/watch?v=jqxENMKaeCU
because it's important!
breitsch
User avatar
santscho
Posts: 1442
Joined: Mon 2. Apr 2007, 08:56
Location: Schweiz

Re: [done]Nach Upgrade auf 1.4.0: Flash funktioniert nicht mehr

Post by santscho »

Wow! Das klingt wirklich heiss, cool und spannend zugleich! Fast wie Kinder-Überraschung. Freu mich schon drauf!
Schon Konfuzius sagte: "Sei kein YAML-Lappen". YAML-phpwcms-Integration auf http://www.yaml.phpwcms.org
Post Reply