United Domains - Migration erfolgreich, Frontend futsch

Hier bekommst Du deutschsprachigen Support. Keine Fehlermeldungen oder Erweiterungswünsche bitte!
Post Reply
User avatar
Klappstuhl28
Posts: 832
Joined: Fri 4. Mar 2005, 01:58
Location: Hamburg
Contact:

United Domains - Migration erfolgreich, Frontend futsch

Post by Klappstuhl28 » Wed 1. May 2019, 20:04

Ich verwende die aktuelle phpwcms Version 1.9.8 mit php7.1 auf einem United Domains Webspace.
Funktioniert auch alles super. Jetzt hatte United Domains neuen Webspace angeboten mit SSL-Zertifikat (openssl) mehr Arbeitsspeicher, PHP-Version 7.3 usw.
Also die Ordner auf den neuen Webspace hochgeladen. Der Aufruf der Installation klappte unlogischerweise hinten und vorne nicht. 403, 404... Der Support meinte, daran wäre das cms Schuld. Ich meine, dass da andere Einstellungen wie u.a. vermutlich in Verbindung mit dem Redirect auf https:// stehende Geschichten dafür verantwortlich sind. Ich konnte auch statischen Content in der Installation nicht erreichen.

"Not Found

The requested URL /kunden/homepages/35/d429500/htdocs/.../index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Der Support hat das dann (vermeintlich) hinbekommen. Ich konnte immerhin die Installation erreichen.

Also die alte Datenbank eingepackt auf der neuen Installation hochgeladen. Im Backend eingeloggt. Alles super ohne Probleme. Login ist erreichbar. Texte sind da, Aliasse sind da, alles da. Nur ist das frontend weg. Immerhin wird auf die Fehlerseite umgeleitet.
Ohne Fehlerseite sind wir immer noch bei:

Not Found

The requested URL /kunden/homepages/35/d429500/htdocs/.../index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

// site values
$phpwcms['site'] = 'https://www.webseite.tld'; // recommend 'http://'.$_SERVER['SERVER_NAME'].'/' ($... hatte ich auch schon, http:// hatte ich auch schon)
$phpwcms['site_ssl_mode'] = 1; // turns the SSL Support of WCMS on (1) or off (0), default value 0
$phpwcms['site_ssl_url'] = 'https://'.$_SERVER['SERVER_NAME'].'/'; // URL assigned to the SSL Certificate. Recommend 'https://'.$_SERVER['SERVER_NAME'].'/'
$phpwcms['site_ssl_port'] = 443; // The Port on which you SSL Service serve the secure Sites, default SSL port is 443

dann noch:
$phpwcms['db_pers'] = 1;

und

$phpwcms['DOC_ROOT'] = $_SERVER['DOCUMENT_ROOT'];// current DOC_ROOT seems to be: '/homepages/35/tralala'
$phpwcms['root'] = 'Unterordner der Installation'; //default: ''

Eine .htacces, die u.a. die 301-Umleitung alter Links regelt oder die Umleitung auf www. hatte ich deaktiviert und so, auch wenn ich mir davon nicht wirklich etwas versprochen hatte.

Hatte jemand etwas in dieser Art und konnte eine Lösung finden?
Die alte Installation läuft wie gesagt einwandfrei.

Ich würde es mit der SSL-Geschichte in Verbindung

Ich weiß ehrlich gesagt nicht, was ich noch versuchen soll. Ich hatte auch schon im Forum geschaut, aber nichts passendes gefunden.
Lars

Don't say you don't have enough time. You have exactly the same number of hours per day that were given to Helen Keller, Pasteur, Michaelangelo, Mother Teresa, Leonardo da Vinci, Thomas Jefferson, and Albert Einstein. - H. Jackson Brown -

User avatar
Klappstuhl28
Posts: 832
Joined: Fri 4. Mar 2005, 01:58
Location: Hamburg
Contact:

Re: United Domains - Migration erfolgreich, Frontend futsch

Post by Klappstuhl28 » Wed 1. May 2019, 20:30

Ich sehe gerade, die Fehlermeldung spricht von 'kunden/...' und hier $phpwcms['DOC_ROOT'] = $_SERVER['DOCUMENT_ROOT'];// current DOC_ROOT seems to be: '/homepages/35/:::' das ist ja nicht ganz dasselbe. :shock:
Lars

Don't say you don't have enough time. You have exactly the same number of hours per day that were given to Helen Keller, Pasteur, Michaelangelo, Mother Teresa, Leonardo da Vinci, Thomas Jefferson, and Albert Einstein. - H. Jackson Brown -

User avatar
Oliver Georgi
Site Admin
Posts: 9560
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: United Domains - Migration erfolgreich, Frontend futsch

Post by Oliver Georgi » Tue 21. May 2019, 12:45

Prüfe das gegen, indem Du dir mal eine phpinfo() im Verzeichnis öffnest, wo Du phpwcms liegen hast. Dann siehst Du den wahren Pfad zum Document Root. Bei Bedarf hart in $phpwcms['DOC_ROOT'] hinterlegen. Ansonsten sollte auch gehen:

Code: Select all

$phpwcms['DOC_ROOT'] = dirname(dirname(__FILE__));
Die Werte

Code: Select all

$phpwcms['site'] = '';
$phpwcms['site_ssl_url'] = '';
sollten genügen
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

Post Reply