Webseiten Bildproblem bei Facebook

Hier bekommst Du deutschsprachigen Support. Keine Fehlermeldungen oder Erweiterungswünsche bitte!
photojo
Posts: 679
Joined: Wed 15. Nov 2006, 20:02
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by photojo » Tue 19. Jan 2016, 14:10

Hallo andalucia,

wäre nett, wenn du für alle anderen hier im Forum dein Vorgehen kurz umreißen würdest.


LG
Jo

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sun 21. Feb 2016, 10:54

Wäre nett, ja.
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
Oliver Georgi
Site Admin
Posts: 9559
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by Oliver Georgi » Sun 21. Feb 2016, 12:33

Einbindung könnt ihr z.B. hier schauen: http://www.bauhaus-dessau.de/bauhaus-la ... rview.html
Unter dem Hauptinhalt ist der Teilen-Block

Das ist alles Systemstandard, außer die Share-Links selbst. Muss man selbst anpassen, da jeder das etwas anders haben möchte und ich wiederum nichts von den JavaScript-Monstern der jeweiligen Plattformen halte.
Bildschirmfoto 2016-02-21 um 12.29.45.png
Ich arbeite bewußt für die Links nicht mit <a href>, sondern habe dort JavaScript Event draufgehangen, auch wiederum, um den AdSocialBlockern den Wind aus den Segeln zu nehmen, da sonst schnell Löcher im Inhalt entstehen. Technisch ist es sehr stabil so, gleichzeitig muss niemand Cookie-Angst an der Stelle haben und auch datenschutzrechtlich bleibt es sauber.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sun 21. Feb 2016, 12:48

Prima, danke!
Und das Bild wird dann jeweils aus dem Artikelkopfbild genommen? Dann sollte ich wohl besser überall mal Kopfbilder einbauen... ;)
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
Oliver Georgi
Site Admin
Posts: 9559
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by Oliver Georgi » Sun 21. Feb 2016, 14:29

wenn Kopfbild, ja, ansonsten werden alle (System)-Bilder herangezogen. Gibt dann mehrere <og:image> Metaangaben
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sat 5. Mar 2016, 17:22

Irgendwie kriege ich es nicht hin. Wo muss ich was einstellen, damit nicht immer nur die Bilder von den News zB, sondern auch mal das Artikelkopfbild im Quellcode auftaucht oder ein Bild von imagediv oder...
Es kommt immer ein bestimmtes Bild, auch auf Seiten, wo das nicht vorkommt. Steht auch immer im Quellcode. Wohl gefühlte tausend Mal habe ich den FB object debugger neu scrapen lassen, aber nada. Langsam quellen mir überall Hassbeulen raus. Wenn doch wenigstens das hinterlegte Defaultbild erschiene.
Das kann doch nicht so schwer sein, aber es will einfach nicht.......
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
Oliver Georgi
Site Admin
Posts: 9559
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by Oliver Georgi » Sat 5. Mar 2016, 18:20

Du bist Dir sicher, dass Social Setting für den Artikel, die Kategorie aktiv ist? Es ist auch wirklich ein Artikelbild (Listing, Summary) hinterlegt. Du hast das Fallbackbild korrekt definiert: opengraph-default.png?
https://github.com/slackero/phpwcms/tre ... mplate/img
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sat 5. Mar 2016, 18:58

Oliver Georgi wrote:Du bist Dir sicher, dass Social Setting für den Artikel, die Kategorie aktiv ist? Es ist auch wirklich ein Artikelbild (Listing, Summary) hinterlegt. Du hast das Fallbackbild korrekt definiert: opengraph-default.png?
Alles gemacht.
Was mir fehlt (anscheinend), ist der korrekte Aufruf hinter dem FB-Button?
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
Oliver Georgi
Site Admin
Posts: 9559
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by Oliver Georgi » Sun 6. Mar 2016, 06:41

AdBlocker? SocialBlocker? Ich nutze keine der von Twitter oder FB angebotenen Einbettungslösungen mehr, da zumeist jeder dieser Buttons herausgefiltert wird und somit nicht mehr sichtbar ist.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sun 6. Mar 2016, 10:50

Oliver Georgi wrote:AdBlocker? SocialBlocker?
Nein, keine bzw. abgeschaltet. Ich probiere mal weiter ;)
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sun 6. Mar 2016, 12:02

Oliver Georgi wrote:Ich nutze keine der von Twitter oder FB angebotenen Einbettungslösungen mehr
Ich ja auch nicht (wg datenschutz und so)
Aber wie dann?
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
Oliver Georgi
Site Admin
Posts: 9559
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by Oliver Georgi » Sun 6. Mar 2016, 14:27

Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Sun 6. Mar 2016, 22:07

Und wie bekomme ich diese Tags <!--SOCIAL-TOOLS--> bzw <!--RELATED_DETAIL_PREFIX--> zum Klingen?
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

User avatar
Oliver Georgi
Site Admin
Posts: 9559
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Webseiten Bildproblem bei Facebook

Post by Oliver Georgi » Mon 7. Mar 2016, 05:54

update wrote:Und wie bekomme ich diese Tags <!--SOCIAL-TOOLS--> bzw <!--RELATED_DETAIL_PREFIX--> zum Klingen?
Das sind projektbezogene Ersetzer, die Lösung ist der HTML-Part. Ein bißchen musste schon investieren und entsprechend Deines Bedarfs adaptieren. Siehe doch mein Link zum Artikel, bei dem das live im Einsatz ist.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон

User avatar
update
Moderator
Posts: 6394
Joined: Mon 10. Jan 2005, 17:29
Location: germany / outdoor

Re: Webseiten Bildproblem bei Facebook

Post by update » Mon 7. Mar 2016, 08:34

Ich habe jetzt im Quellcode (Newsseite)

Code: Select all

  <meta property="og:type" content="article">
  <meta property="og:title" content="MYKKET MORTON in Concert">
  <meta property="og:url" content="http://mykketmorton.com/mykket-morton-in-concert.html">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/123.png">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/125.jpg">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/177.png">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/178.png">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/197.png">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/115.jpg">
  <meta property="og:image" content="http://mykketmorton.com/img/cmsimage.php/500x500x0/41e05e31dca3f10b68ba8c9d56c03675.jpg">
Die Bilder 123, 125 usw kommen aus den Newseinträgen, das 41e05e31dca3f10b68ba8c9d56c03675 ist das Kopfbild.
Das wird aber nicht angeboten, auch nicht der Teasertext dazu, sondern ein Text aus der description (aber mittlerweile gelöscht). Mit erneutem FB-scraping nicht wegzubekommen (cache-Problem?)
Ich versuch's nachher nochmal...
It's mostly all about webdesign, logo design, new and old pages refresh, print BUT slowly switching to be supporter for the band Mykket Morton. Visit Mykket Morton on FB. Listen Mykket Morton and live videos on youtube.

Post Reply