Problem bei RSS Erstellung r495

Hier bekommst Du deutschsprachigen Support. Keine Fehlermeldungen oder Erweiterungswünsche bitte!
Post Reply
phalancs
Posts: 792
Joined: Thu 19. Feb 2004, 05:09
Location: Germany

Problem bei RSS Erstellung r495

Post by phalancs »

Nach dem Update erhalte ich beim Erstellen des RSS Feeds folgende Meldungen:

Code: Select all

Warning: Invalid argument supplied for foreach() in /var/www/web32/html/cms2/include/inc_lib/default.inc.php on line 411

Warning: Invalid argument supplied for foreach() in /var/www/web32/html/cms2/include/inc_lib/default.inc.php on line 411

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web32/html/cms2/include/inc_lib/default.inc.php:411) in /var/www/web32/html/cms2/include/inc_ext/feedcreator/feedcreator.class.php on line 778

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web32/html/cms2/include/inc_lib/default.inc.php:411) in /var/www/web32/html/cms2/include/inc_ext/feedcreator/feedcreator.class.php on line 779
Woran könnte das liegen? Mit der r470 gabs diese Fehler nicht.
P.S.: Ich habe nur die Dateien geändert, die Datenbank nicht. Denke das gab da aber keine Änderungen, oder?

P.P.S.: Habe das Problem eingegrenzt. Es muss an der front.func.inc.php liegen, mit der alten aus r470 gunktioniert das rss Erstellen.

P.P.P.S.: Ich glaube es ist mein eigener Fehler... :O

P.P.P.P.S.: Nee habs gefunden, es liegt an folgender Zeile:

Code: Select all

	$replace[0]		= '<a href="'.rel_url().'#top" class="phpwcmsTopLink">$1</a>';
Ich weiß nicht warum, aber wenn ich diese wieder auf das setze was in der r470 steht, dann funktioneirt das rss Erstellen wieder tadellos. Sorry Oli, wenn ich hier wieder Code einfüge. Ich möchte nur meinen Lösungsweg transparent machen.
Als Disclaimer rate ich also allen von der Verwendung ab :)

Habe es so abgeändert:

Code: Select all

	$replace[0]		= '<a href="#top" class="phpwcmsTopLink">$1</a>';
2008
User avatar
Oliver Georgi
Site Admin
Posts: 9732
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Problem bei RSS Erstellung r495

Post by Oliver Georgi »

dann pack es in Hacks. Mit URL-Rewrite wird Dir das wieder um die Ohren fliegen.

Meiner Meinung nach resettest Du Dir an irgendeiner Stelle die Variable $_getVar!

Habs aber optimiert und Fallback integriert…
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
dani
Posts: 45
Joined: Sat 21. Jan 2006, 19:39
Location: Germany
Contact:

Re: Problem bei RSS Erstellung r495

Post by dani »

Ich habe ein Update auf die r491 gemacht und auch bei mir funktioniert RSS Feed jetzt nicht mehr. Gleicher Fehler wie hier beschrieben. da ich nicht im Code rumbasteln möchte.
Ab welcher Version funktioniert RSS, auch bei URL-Rewrite wieder?

Im Commit Log kann ich keine Infos zur Anpassung finden?
Oliver Georgi wrote:...Habs aber optimiert und Fallback integriert…
User avatar
Oliver Georgi
Site Admin
Posts: 9732
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Problem bei RSS Erstellung r495

Post by Oliver Georgi »

dani wrote:Im Commit Log kann ich keine Infos zur Anpassung finden?
Oliver Georgi wrote:...Habs aber optimiert und Fallback integriert…
Auch noch nicht veröffentlicht Der Fallback ist in r496 enthalten.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
dani
Posts: 45
Joined: Sat 21. Jan 2006, 19:39
Location: Germany
Contact:

Re: Problem bei RSS Erstellung r495

Post by dani »

Hallo Oliver,
das geht ja fix. Da werd ich mich am Wochenende ans Update machen.

Daniel
Post Reply