Weiterleitung auf Startseite funktioniert nicht

Hier bekommst Du deutschsprachigen Support. Keine Fehlermeldungen oder Erweiterungswünsche bitte!
Post Reply
der Jerg
Posts: 11
Joined: Wed 2. Jan 2019, 15:27

Weiterleitung auf Startseite funktioniert nicht

Post by der Jerg »

Hallo liebe Gemeinde,
spannenderweise habe ich vor drei Jahren einen ganz ähnlichen Thread gestartet. Diesmal ist das Problem jedoch ein wenig anders gelagert.

Ich habe wegen der Providerseitigen-Umstellung auf PHP7.4 ein wenig an der betreffenden Seite gebastelt.
Das Frontend funktionierte vorher noch, einloggen war aber nicht mehr möglich.
Komischerweise habe ich nun nach ein wenig Tüftelei das Problem, dass nach aufruf der Domain nicht mehr auf die Startseite weitergeleitet wird, ich erhalte nur die 404-Seite.

Die Datenbank ist nun aber wieder im Ursprungszustand, die Dateien auch.

In der conf.indexpage.inc.php sind die richtigen Daten hinterlegt (funktionierte ja vorher auch super), aber sie werden einfach nicht mehr genutzt.

Was könnte da los sein?

Gebe ich direkt "domain.de/index.php?willkommen" ein, funktioniert alles super, ansonsten tut sich aber nichts. Der Aufruf der index.php selber rendert am Ende 404.

Liebe Grüße
Jerg
User avatar
top
Posts: 509
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: Weiterleitung auf Startseite funktioniert nicht

Post by top »

der Jerg wrote: Tue 16. Nov 2021, 21:39...
In der conf.indexpage.inc.php sind die richtigen Daten hinterlegt (funktionierte ja vorher auch super), aber sie werden einfach nicht mehr genutzt.
...
In der Datei gab es vor Kurzem eine Änderung von

Code: Select all

$indexpage['acat_alias'] = 'index';
nach:

Code: Select all

$indexpage['acat_alias'] = 'index-view';
Eventuell hängt es damit zusammen?
der Jerg
Posts: 11
Joined: Wed 2. Jan 2019, 15:27

Re: Weiterleitung auf Startseite funktioniert nicht

Post by der Jerg »

Habe ich probiert: hilft leider nicht.

Zuletzt stand da bei mir

Code: Select all

$indexpage['acat_name'] = 'Root';
$indexpage['acat_alias'] = 'root';
$indexpage['acat_aktiv'] = 1;
$indexpage['acat_redirect'] = 'index.php?willkommen';
drin und es funktionierte.
Nun ist es jedoch so, dass ich da reinschreiben kann, was ich will, es ändert einfach nichts.
User avatar
Uwe367
Posts: 1144
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Weiterleitung auf Startseite funktioniert nicht

Post by Uwe367 »

Was darf man denn unter "ein wenig Tüftelei" verstehen?
Man sollte generell nicht nur ein paar Dateien ändern bzw. anpassen, sondern ein komplettes Systemupdate durchlaufen lassen um ALLE relevanten Dateien auf den neuesten Stand zu bringen und ich vermute daß da auch der Fehler liegt.
der Jerg
Posts: 11
Joined: Wed 2. Jan 2019, 15:27

Re: Weiterleitung auf Startseite funktioniert nicht

Post by der Jerg »

Ja, Mama. :)
Weiß ich doch. Aber das ist de facto doch auch egal.
Wie gesagt: es sind komplett alle Dateien wieder im Ursprungszustand, ohne Ausnahme. Die Datenbank ist komplett wiederhergestellt, auch in der richtigen collation und am Server hab ich nichts geändert, da ich den nicht selbst betreibe, sondern es nur ein kleines Webhosting-Paket bei Hosteurope ist.

Dennoch: die Tüftelei sah wie folgt aus:
- Ich habe Backups gemacht
- die neue Version in einen Unterordner gepackt
- beim Aufrufen des Setups gemerkt, dass ich nach dem Akzeptieren der Lizenz zum Login kam (??)
- weil mir das Spanisch vorkam, habe ich die "update" und die "root"-Version getauscht, um zu sehen, ob das Unterverzeichnis Probleme macht
- weil alles nix half habe ich aus Spaß einfach mal eine neuinstallation auf einer frischen DB gemacht
- dann musste ich aus Zeitgründen abbrechen, hab die alte DB und die Dateien wiederhergestellt und das Ergebnis war nun das. OBWOHL beim "Dreieckstausch" zwischen neu und alt auch keine Probleme entstanden...

Ich bin ein wenig ratlos:).
Habe mich schon ganz schön tief in den Code gefummelt, um zu verstehen, wie die Seite aufgebaut wird. Den Zeitpunkt, an dem die Werte der conf.indexpage.inc.php genutzt werden, habe ich aber noch nicht gefunden und bin ehrlich gesagt auch gar nicht so scharf darauf;).

Danke und liebe Grüße
Jerg
User avatar
Uwe367
Posts: 1144
Joined: Sat 15. Sep 2007, 07:19
Location: Koblenz

Re: Weiterleitung auf Startseite funktioniert nicht

Post by Uwe367 »

Wenn du alles wieder auf Ursprungszustand zurück gesetzt hast sollte das auch wieder funktionieren wie vor der Tüftelei.
Von daher muß da wohl noch irgendetwas "hängen" geblieben sein was dir nun Probleme macht, aber das zu erraten ist wie die Suche nach der Stecknadel im Heuhaufen. Vielleicht schaut Oliver mal hier vorbei und kann dir den entscheidenden Tip geben.
der Jerg
Posts: 11
Joined: Wed 2. Jan 2019, 15:27

Re: Weiterleitung auf Startseite funktioniert nicht

Post by der Jerg »

edit: gelöscht, weil voreilig
User avatar
Oliver Georgi
Site Admin
Posts: 9796
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: Weiterleitung auf Startseite funktioniert nicht

Post by Oliver Georgi »

Daran denken, dass manche Browser eine einmal durchgelaufene Weiterleitung automatisch immer wieder sofort auflösen, also mal anderen Browser versuchen. Immer auch den Browsercache deaktivieren oder für die Domain löschen.

Bevor man mit einem Update anfängt, macht man eine lauffähige Kopie der Altinstallation. Und besser nicht in einem Unterverzeichnis, sondern auf einer Subdomain. Wenn das so geht wie vorher, dann geht man an das Update. Ich mache es immer lokal, da habe ich volle Kontrolle.

Immer auch an die .htaccess denken, base href bei Bedarf setzen, auf http/https achten.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
der Jerg
Posts: 11
Joined: Wed 2. Jan 2019, 15:27

Re: Weiterleitung auf Startseite funktioniert nicht

Post by der Jerg »

Danke, das sind nochmal gute Tips fürs nächste Mal.

Ich habe es eben gelöst bekommen, indem ich eine Neuinstallation vorgenommen habe, der ich sukzessive die Dateien mit eigenem Inhalt zugefügt habe.

Ich hab jetzt noch ein anderes Problem, aber das soll an anderer Stelle geklärt werden:).
Post Reply