"Fehler beim Anmelden" nach Update

Hier bekommst Du deutschsprachigen Support. Keine Fehlermeldungen oder Erweiterungswünsche bitte!
dani
Posts: 60
Joined: Sat 21. Jan 2006, 19:39
Location: Germany
Contact:

Re: "Fehler beim Anmelden" nach Update

Post by dani »

Dieter:Bahr wrote: Thu 16. Sep 2021, 18:30 Jeder Browser alle Cookies und cache geleert.
Um welche Datei handelt es sich im dev?
Bei meinem Zusatz "Update:" meinte ich mit "Dev", dass Du mindestens folgende PHPWCMS Version installiert haben musst, welche zur Zeit halt noch im Github Branch "v1.9-dev" (https://github.com/slackero/phpwcms/branches) ist. Sollte ein zusätzlicher Hinweis zur Fehlersuche sein.

Dieser Commit hat die Änderung:
https://github.com/slackero/phpwcms/com ... bc950d41ca

Code: Select all

include/inc_lib/revision/revision.php
define('PHPWCMS_VERSION', '1.9.29-dev');
define('PHPWCMS_RELEASE_DATE', '2021/09/09');
define('PHPWCMS_REVISION', '552');
Dies wäre der Download Link für die Dev Version:
https://github.com/slackero/phpwcms/arc ... .9-dev.zip

Einzelne Dateien tauschen ist umständlicher.
User avatar
Oliver Georgi
Site Admin
Posts: 9800
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: "Fehler beim Anmelden" nach Update

Post by Oliver Georgi »

ja, auch das, sorry – klar die Änderungen sind noch nicht im Master angekommen. Ich mache das am Wochenende.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
User avatar
Oliver Georgi
Site Admin
Posts: 9800
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: "Fehler beim Anmelden" nach Update

Post by Oliver Georgi »

Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
User avatar
top
Posts: 509
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: "Fehler beim Anmelden" nach Update

Post by top »

Irgendwie scheint da noch der Wurm drin zu sein. Ich versuche seit ein paar Stunden eine neue Installation (phpwcms 1.9.31-dev 2021/10/17, r553) zu installieren und komme anschließend nicht ins Backend.
(Frische Installation in neu angelegter Sub-Domain, neu angelegte Datenbank.)

Durch den Thread hier bin ich mal auf die Idee gekommen es mit dem Firefox zu versuchen. Und siehe da - hier geht es. Scheinbar funktioniert es aktuell nur mit Browsern, die nicht auf die Chromium-Engine setzen.
Mit Google-Chrome, Opera, Edge und Vivaldi bekomme ich also immer einen "Fehler beim Anmelden!"
Funktionieren tut es mit Firefox, IE11 und selbst mit dem guten alten Safari 5.1.7 komme ich ins Backend.
Ach ja, ich arbeite hier mit Windows 10 Pro, falls das von Bedeutung ist.
User avatar
Oliver Georgi
Site Admin
Posts: 9800
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: "Fehler beim Anmelden" nach Update

Post by Oliver Georgi »

Nein, es hat damit zu tun, dass Du eine alte PHP Session hast, die Dich daran hindert, zuzugreifen. Lösche alle Cookies, die in der Loginmaske hinterlegt sind. Dass es im Firefox geht, liegt genau daran – die Session war nicht vorhanden und andere Cookies auch nicht.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
User avatar
top
Posts: 509
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: "Fehler beim Anmelden" nach Update

Post by top »

Du hast recht, mit dem Löschen der Cookies (und erneutem Laden des Login-Screens) konnte ich mich wieder anmelden. Die Login-Probleme die ich später auch in anderen Browsern hatte, führe ich mal auf mein dilettantisches Stochern in der conf.inc.php zurück. :wink:

Ich habe mir trotzdem noch mal die Mühe gemacht meinen Fehler zu reproduzieren. Also 3. Provider (nach DF und Strato mal bei IONOS), neue Subdomain bei ungenutzter Domain angelegt und eine neue Datenbank erstellt. (Die Domain hatte ich vorher sicherlich nie in diesem Browser geöffnet.)
Nach dem Installationsprozess hänge ich bei der Anmeldung wieder bei "Fehler beim Anmelden".

Durch das Löschen der Cookies geht es dann wie gewünscht, gewollt ist dieser Schritt aber sicherlich nicht.

Beim weiteren Wiederholen ist mir noch folgendes aufgefallen:
Das Setup erzeugte ein Cookie "PHPSESSID" für test.example.com (ohne! Punkt am Anfang)
Der Login erzeugte ein Cookie "PHPSESSID" für .test.example.com (mit! Punkt am Anfang)
User avatar
Oliver Georgi
Site Admin
Posts: 9800
Joined: Fri 3. Oct 2003, 22:22
Location: Moscow, Russia
Contact:

Re: "Fehler beim Anmelden" nach Update

Post by Oliver Georgi »

Setup möglich, ich muss da selbst noch mal schauen, ziemlich komplex mit den ganzen Änderungen.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Систрон
Post Reply