Handling Phpwcms Version 1.8.6 / 1.9

If you have created additional (non official) documentation or tutorials or something like that please post this here
Dieter:Bahr
Posts: 3
Joined: Tue 28. Feb 2017, 11:18

Handling Phpwcms Version 1.8.6 / 1.9

Postby Dieter:Bahr » Tue 28. Feb 2017, 11:37

Hallo zusammen,
nachdem ich hier neu bin, und keinerlei Ahnung habe wo ich mein Anliegen hier veröffentlichen soll, mach ich das jetzt ma ganz einfach hier, da ich denke, das man mir schon sagen wird wo hin damit, wenn es denn wo anders hin gehört.

Ich probiere derzeit etwas mit Version 1.8.6 und 1.9 rum und bin mir nicht sicher, ob ich evtl. irgendwo Fehler mache, oder diese in dem
CMS sind :-(

Und zwar, hab ich z.B. bei dem neuen Template imagetext Bootstrap.tmpl folgendes festgestellt.

1.) Galerie funktioniert bei mir überhaupt nicht mehr mit dem Template Bootstrap.tmpl
im Standard template wird für das Replacemant-Tag {IMAGE} folgendes generiert

Code: Select all

<img src="content/images/dcac0cc8fb4ffdf26607aeea531ed5d4.jpg" width="400" height="250" data-image-id="5" data-image-hash="38bb0c2bedb9f3b98eef94ef14ed047f" border="0" class="image-img" alt="beispiel.jpg">


Bei dem neuen Template wird folgendes generiert

Code: Select all

<img src="img/cmsimage.php/400x250x1/38bb0c2bedb9f3b98eef94ef14ed047f.jpg" alt="beispiel.jpg">


Ergebnis ist dann, das das Bild nicht in Lightbox oder sonst irgendwie Klickbar ist.

Cool finde ich, das man nun dem Artikel Klassen mit geben kann! Super Geschichte. Was ich nun in Version 1.8.4 festgestellt hatte, war, das spaceAfterCP nur mit einem Trick funktioniert hatte, indem man Top-Link im Artikel gewählt hatte oder im CSS eine

Code: Select all

.spaceAfterCP      { clear: both; height: 1px; margin-top: -1px;}

eingefügt hatte. In Version 1.8.5 war dann alles wieder Prima. In der Version 1.8.6 taucht bei mir dieses Problem wieder auf und der CSS Eintrag macht das Ganze auch nicht wieder gut. Bei mir hilft dann nur wieder den Top-Link zu wählen.

Danke bereits im Voraus,

Gruß Dieter

User avatar
Oliver Georgi
Site Admin
Posts: 9397
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: Handling Phpwcms Version 1.8.6 / 1.9

Postby Oliver Georgi » Tue 28. Feb 2017, 12:13

Das Bootstrap Template ist komplett custom, man muss sich also um die Lightbox etc. kümmern oder es entsprechend selbst im Template einbauen. Das ist ja nur ein Mustertemplate, viele Optionen.

Was die Spacer betrifft, schau Dir den generierten Source-Code an. Die Klassen sind von Deiner Konfiguration abhängig. Im CSS sollten keine Höhen definiert werden dafür, da diese ja im Code mitgegeben werden. Siehe auch https://github.com/slackero/phpwcms/blo ... #L146-L149 – dann erklärt sich das Verhalten. Schau Dir den Tag an, der generiert wird. Wenn Du ein Block-Element benötigst, der Klasse display: block; mitgeben.

Ich gehe immer mehr weg von einer universellen "Standard"-Lösung, da der eine Bootstrap nutzt, der andere was anderes. Fast alle Klassen können in der conf.template-default.inc.php selbst angepasst und konfiguriert werden.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn

Old Boy
Posts: 994
Joined: Fri 23. Nov 2012, 13:52

Re: Handling Phpwcms Version 1.8.6 / 1.9

Postby Old Boy » Tue 28. Feb 2017, 12:40

Na prima, da hat die Anmeldung im Forum also doch geklappt.

Bezüglich des Bild PopUps: viewtopic.php?f=16&t=25037


Return to “(unofficial) tutorials & documentation”

Who is online

Users browsing this forum: No registered users and 1 guest