Fatal error: Call to undefined function: imagettfbbox()

Get help with installation and running phpwcms here. Please do not post bug reports or feature requests here.
Post Reply
Dave_G
Posts: 20
Joined: Wed 19. Jan 2005, 17:57
Location: Washington, DC

Fatal error: Call to undefined function: imagettfbbox()

Post by Dave_G » Thu 28. Apr 2005, 03:04

Hey Guys,

Is there any other reason why this would problem would occur? I read some other posts saying that this error happens when I have a PHP version below 4.3.8, but I'm running version 4.3.11.

I just started getting this error! I had another post stating just my GT Mod wasn't working, but now whenever I go to a page that uses the GT Mod I get this:

Fatal error: Call to undefined function: imagettfbbox() in /home2/davegor/public_html/phpwcms/include/inc_module/mod_graphical_text/inc_front/gt.func.inc.php on line 49


Any ideas? Sorry for so many posts lately, but can you tell I just started working on my site again?!

Thanks!
-Dave

brans

Post by brans » Thu 28. Apr 2005, 11:36

there might some module (like GD or ImageMagick missing) you could maybe try to go for: http://www.phpwcms.de/forum/viewtopic.php?t=6416

User avatar
Rainer G
Posts: 377
Joined: Wed 16. Feb 2005, 10:26
Location: Hannover - Germany
Contact:

Post by Rainer G » Thu 28. Apr 2005, 11:46

Hm! :shock:
This function should be run with this PHP versions:
PHP 3>= 3.0.1, PHP 4 , PHP 5

Look here:
http://de2.php.net/manual/de/function.imagettfbbox.php

Dave_G
Posts: 20
Joined: Wed 19. Jan 2005, 17:57
Location: Washington, DC

Post by Dave_G » Thu 28. Apr 2005, 19:12

Yeah, it's very strange.

I'll have to check with my hosting company and make sure it's installed, but I am very certain it is! I just double checked my phpInfo and it's in there!

I took a glance at Fontizer, but not too sure how to get that to work in phpwcms...would it just be called as a CSS function?

Thanks for the thoughts guys. I really do love my phpwcms!

-Dave

User avatar
pico
Posts: 2595
Joined: Wed 28. Jul 2004, 18:04
Location: Frankfurt/M Germany
Contact:

Post by pico » Fri 29. Apr 2005, 08:27

Hi

did you upload a valid TTF-Font to ../inc_fonts/ ?

maybe try another Font
Lieber Gott gib mir Geduld - ABER BEEIL DICH
Horst - find me at Musiker-Board

Post Reply