NAV_LIST_UL >= V1.30

Get help with installation and running phpwcms here. Please do not post bug reports or feature requests here.
User avatar
Jensensen
Posts: 2986
Joined: Tue 17. Oct 2006, 21:11
Location: auf der mlauer

Re: NAV_LIST_UL >= V1.30

Post by Jensensen » Thu 17. Jan 2013, 20:39

Oops! There must be something wrong with NAV_LIST_UL in newer versions of phpwcms -> 1.6.528 (2012/12/05, r528).

When I use an older version of
// original function buildCascadingMenu in /include/inc_front/front.func.inc.php

as it IS still used here NLU_FF_AC_QD
http://forum.phpwcms.org/viewtopic.php?f=8&t=17891

the output I get is

Code: Select all

<ul class="act_path">
{so_much} | Knick-Knack. | GitHub
Umlaute im URL sind meistens immer Kacke.

User avatar
Jensensen
Posts: 2986
Joined: Tue 17. Oct 2006, 21:11
Location: auf der mlauer

Re: NAV_LIST_UL >= V1.30

Post by Jensensen » Wed 17. Apr 2013, 21:47

I'm still testing...

some newer information can be found here: https://github.com/slackero/phpwcms/issues/13
The default behavior is:

Code: Select all

start_id,
max_level_depth,
class_path | ul_class_level1 | ul_class_level2 | ...,
class_active_li | class_active_a,
ul_id_name,
wrap_ul_div(0 = off, 1 = <div>, 2 = <div id="">, 3 = <div class="navLevel-0">),
wrap_link_text(<em>|</em>, articlemenu_start_level)```
{so_much} | Knick-Knack. | GitHub
Umlaute im URL sind meistens immer Kacke.

User avatar
juergen
Moderator
Posts: 4549
Joined: Mon 10. Jan 2005, 18:10
Location: Weinheim
Contact:

Re: NAV_LIST_UL >= V1.30

Post by juergen » Wed 28. Mar 2018, 18:10

Is this still "state of the art" ?

just moving and updating a Site, but the context of NAV_LIST_UL is not working
{NAV_LIST_UL:FP,0,1,art-hmenu,active,,,,} ... or should I check source?

No Howto for Version >= 1.8.9 found yet

Ok ! Found this:
EDIT: But the <ul class="any".... is not injected .. what is wrong with my Tag ?

Answer: Was the missing of a Komma in the end ... the bold one ...

Code: Select all

 @string $parameter:
            menu_type,
            start_id,
            max_level_depth,
            class_path|ul_class_level1|ul_class_level2|...,
            class_active_li|class_active_a,
            ul_id_name,
            wrap_ul_div(0 = off, 1 = <div>, 2 = <div id="">, 3 = <div class="navLevel-0">),
            wrap_link_text(<em>|</em>),
            articlemenu_start_level|articlemenu_list_image_size (WxHxCROP OR WxHxCROP)|_
                articlemenu_use_text (take text from: description:MAXLEN OR menutitle:MAXLEN OR teaser:MAXLEN OR teaser:HTML)|_
                articlemenu_position (inside|outside)|_
                <custom>[TEXT]{TEXT}[/TEXT][IMAGE]<img src="{IMAGE}" alt="{IMAGE_NAME}">[/IMAGE]</custom>

User avatar
Oliver Georgi
Site Admin
Posts: 9442
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: NAV_LIST_UL >= V1.30

Post by Oliver Georgi » Thu 29. Mar 2018, 05:49

juergen wrote:
Wed 28. Mar 2018, 18:10
Answer: Was the missing of a Komma in the end ... the bold one ...
8)
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Post Reply