navigation and images missing after upgrade

Get help with installation and running phpwcms here. Please do not post bug reports or feature requests here.
Post Reply
jadoube
Posts: 18
Joined: Thu 15. Nov 2007, 20:21

navigation and images missing after upgrade

Post by jadoube » Sat 26. Aug 2017, 12:24

I have upgraded from 1.3.3 to 1.8.9, following http://www.phpwcms-howto.de/wiki/doku.p ... ion/update as best as I could.

Now I have ended up with a homepage without navigation and without images in the header and the left column:
http://www.sc-unterhaching.de

My questions:

I have found here that {NAV_TABLE_COLUMN:0} is deprecated, but I can't find a beginner's documentation on navigation. I want a vertical navigation with several expandable levels
1
1.1
2
2.1
2.1.1
etc.

Where are the images referenced by "{IMAGE:logo.png}" looked for? Or do I have to reference them otherwise now?

jadoube
Posts: 18
Joined: Thu 15. Nov 2007, 20:21

Re: navigation and images missing after upgrade

Post by jadoube » Sat 26. Aug 2017, 12:35

In case it matters:
My (new) PHP version is 5.6.31 (the previous one was 5.3).

User avatar
top
Posts: 430
Joined: Fri 11. Aug 2006, 15:03
Location: Eutin

Re: navigation and images missing after upgrade

Post by top » Sat 26. Aug 2017, 14:52

Have you test to set "true" in include/config/conf.inc.php in this line?

Code: Select all

$phpwcms['enable_deprecated']   = false; // enable/disable deprecated functionality, enable if you miss things

jadoube
Posts: 18
Joined: Thu 15. Nov 2007, 20:21

Re: navigation and images missing after upgrade

Post by jadoube » Sat 26. Aug 2017, 19:52

Thank you, it helped - at least in so far that now I can see some kind of navigation and pictures again, although it doesn't quite look like before.
It seems that I'll have to study the possibilities of navigation in the new version ...
http://sc-unterhaching.de

Old Boy
Posts: 1014
Joined: Fri 23. Nov 2012, 13:52

Re: navigation and images missing after upgrade

Post by Old Boy » Sat 26. Aug 2017, 22:44

Ja, da schau her, pepes uraltes Template als Basis ... das ist aber laaange her!

Da war ein Update aber wirklich überfällig und das Nachlesen der inzwischen erfolgten Änderungen ist dringend angeraten!
Es hat sich sehr viel geändert inzwischen, insbesondere die Navigation sollte auf nav_list_ul umgestellt werden, um alle neuen Möglichkeiten nutzen zu können!
Auch bei den Bildern muß neu nachgedacht werden. So einfach wie mit dem ContentPart BILDER geht es heute längst nicht mehr, dafür ist die Zahl der Möglichkeiten aber exponentiell angestiegen!

MAch dich auf ein paar lange Wochenenden gefasst ... aber, es lohnt sich :D

jadoube
Posts: 18
Joined: Thu 15. Nov 2007, 20:21

Re: navigation and images missing after upgrade

Post by jadoube » Sun 27. Aug 2017, 12:00

Ich würde ja gerne lesen, aber WO?
Wo finde ich z.B., wie ich die Bilder jetzt stattdessen einbinden kann?

Neues Problem:
Ich kann zwar Content verändern, aber keine neuen Artikel hinzufügen oder editieren. Hat sich da an der Struktur etwas geändert?
Bestehende Artikel kann ich zwar editieren und sichern, die Änderung wird jedoch schlicht ignoriert.

User avatar
Oliver Georgi
Site Admin
Posts: 9436
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: navigation and images missing after upgrade

Post by Oliver Georgi » Sun 27. Aug 2017, 12:47

Beim Update wirst Du nicht ausreichend sauber vorgegangen sein. Passiert.
  1. Ausloggen
  2. content/tmp bis auf index.html leeren
  3. Loginmaske aufrufen
  4. Noch mal prüfen, sollten nahtlos alle Revisionen als r*.tmp vorhanden sein von r401–r547
Damit sollten Deine Probleme im Backend weg sein.

Die Methode zum Bildeinbinden funktioniert wie gehabt und am Template selbst keine Änderung erforderlich. Die Info war so also nicht korrekt. Prüfen, ob Du Charset umgestellt hast, dann kann passieren, dass manche Bilder nicht mehr sauber laufen. Dann kommst Du um Neuzuweisung nicht herum.

Und da Du sowieso gerade dabei bist, nimm die letzte 1.9er Beta (ist stabil und weiter als 1.8.9, den alten Zweig entwickle ich nicht mehr aktiv weiter).
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Old Boy
Posts: 1014
Joined: Fri 23. Nov 2012, 13:52

Re: navigation and images missing after upgrade

Post by Old Boy » Mon 28. Aug 2017, 01:18

Oliver Georgi wrote:...
Die Methode zum Bildeinbinden funktioniert wie gehabt und am Template selbst keine Änderung erforderlich. Die Info war so also nicht korrekt.
...
Echt jetzt ???
Bilder in mehreren Spalten und Zeilen mit dem CP Bilder sollte wie gehabt funktionieren, auch mit Einstellung der Abstände horizontal und vertikal über den ContentPart :?

Da muß ich aber mal in mich gehen und überlegen, wieso das bei meinen Sites nicht mehr geklappt hat und ich mich auf Bilder div und Bilder spezial verlegen mußte?! Mhhhh?

User avatar
Oliver Georgi
Site Admin
Posts: 9436
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: navigation and images missing after upgrade

Post by Oliver Georgi » Mon 28. Aug 2017, 04:22

Old Boy wrote:Bilder in mehreren Spalten und Zeilen mit dem CP Bilder sollte wie gehabt funktionieren
Also manchmal sollte man dann schon Klassen bemühen. Und ich kenne kein diesbezügliches Issue. Alte Zöpfe muss man manchmal abschneiden, bzw. neu binden. Es gibt aber keinen zwingenden Grund, den CP umzustellen.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Old Boy
Posts: 1014
Joined: Fri 23. Nov 2012, 13:52

Re: navigation and images missing after upgrade

Post by Old Boy » Mon 28. Aug 2017, 09:11

Ist ja richtig und ich hab die Umstellung ja auch ohne (öffentliches) Murren vorgenommen :D ... nur, "so einfach wie damals" bzw. ohne Anpassung bei älteren Installationen, geht es eben leider nicht, will man ein identisches Ergebnis erhalten :(

User avatar
Oliver Georgi
Site Admin
Posts: 9436
Joined: Fri 3. Oct 2003, 22:22
Location: Dessau
Contact:

Re: navigation and images missing after upgrade

Post by Oliver Georgi » Mon 28. Aug 2017, 11:01

Old Boy wrote:identisches Ergebnis erhalten
That's impossible! Schlicht illusorisch. Dann nicht updaten. Geht ja auch ohne.
Oliver Georgi | phpwcms Developer | GitHub | LinkedIn | Kleintierpraxis am Georgengarten

Post Reply