Search found 9560 matches

by Oliver Georgi
Wed 22. May 2019, 12:11
Forum: phpwcms Installationsprobleme Deutsch
Topic: Fehler bei Upgrade von 1.3.3 nach 1.9.8
Replies: 16
Views: 1850

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Also ich habe Installationen bei Strato am Laufen, also der normalen Endkunden-Hostingumgebung. Ich denke Du hast an irgendeiner Stelle eine Konfiguration nicht so, wie diese seitens Strato sein sollte. Prinzipiell kann ich mir das anschauen, brauche Zugangsdaten. Ist das ein Fehler in phpwcms geht ...
by Oliver Georgi
Wed 22. May 2019, 11:20
Forum: phpwcms Support Deutsch
Topic: Keycloud mit Leerzeichen in den Keys
Replies: 15
Views: 3758

Re: Keycloud mit Leerzeichen in den Keys

Sieht man doch eigentlich nicht. Ansonsten hilft simples JavaScript oder CSS.
by Oliver Georgi
Wed 22. May 2019, 09:28
Forum: phpwcms Support Deutsch
Topic: Keycloud mit Leerzeichen in den Keys
Replies: 15
Views: 3758

Re: Keycloud mit Leerzeichen in den Keys

Stört keinen. Keywords sind eh nicht mehr relevant, zumindest für die großen Suchmaschinen. Die ziehen die Schlagworte längst aus dem Kontext des Inhalts.
by Oliver Georgi
Wed 22. May 2019, 08:42
Forum: phpwcms Support Deutsch
Topic: Keycloud mit Leerzeichen in den Keys
Replies: 15
Views: 3758

Re: Keycloud mit Leerzeichen in den Keys

Gibt es da eine Obergrenze? Und woher weißt Du, welche Wörter Du drin haben möchtest und welche nicht.
by Oliver Georgi
Tue 21. May 2019, 18:24
Forum: phpwcms Installationsprobleme Deutsch
Topic: Update von 1.3.3 auf neueste Version?
Replies: 2
Views: 602

Re: Update von 1.3.3 auf neueste Version?

Ja, MySQL 5.x ist kein Problem. Solange PHP in version 5.x verfügbar ist, sollte es gehen.
by Oliver Georgi
Tue 21. May 2019, 18:20
Forum: phpwcms Installationsprobleme Deutsch
Topic: Upgrade von Version 1.3.5.4 auf 1.7.5 klappt auch nicht
Replies: 2
Views: 367

Re: Upgrade von Version 1.3.5.4 auf 1.7.5 klappt auch nicht

kein PHP7 Support für phpwcms < 1.9 Wie ich schon bei der anderen Version bei Dir geschrieben habe, irgendwas hast Du vergessen anzupassen bzw. stimmt nicht. Beim Upgrade nicht vergessen, dass die config korrekt ist. Eigentlich habe ich alle möglichen Probleme an der Stelle abgefangen und Updates la...
by Oliver Georgi
Tue 21. May 2019, 18:19
Forum: phpwcms Installationsprobleme Deutsch
Topic: Fehler bei Upgrade von 1.3.3 nach 1.9.8
Replies: 16
Views: 1850

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Welche Version nutzt Du? Für mich scheint da einiges bei Dir durcheinander zu sein. Bitte arbeite mit vollständigen Kopien der cms Installation
by Oliver Georgi
Tue 21. May 2019, 12:45
Forum: phpwcms Support Deutsch
Topic: United Domains - Migration erfolgreich, Frontend futsch
Replies: 2
Views: 368

Re: United Domains - Migration erfolgreich, Frontend futsch

Prüfe das gegen, indem Du dir mal eine phpinfo() im Verzeichnis öffnest, wo Du phpwcms liegen hast. Dann siehst Du den wahren Pfad zum Document Root. Bei Bedarf hart in $phpwcms['DOC_ROOT'] hinterlegen. Ansonsten sollte auch gehen: $phpwcms['DOC_ROOT'] = dirname(dirname(__FILE__)); Die Werte $phpwcm...
by Oliver Georgi
Tue 21. May 2019, 12:39
Forum: phpwcms Installationsprobleme Deutsch
Topic: Fehler bei Upgrade von 1.3.3 nach 1.9.8
Replies: 16
Views: 1850

Re: Fehler bei Upgrade von 1.3.3 nach 1.9.8

Schlicht falsche Datenbankkonfiguration: Unknown MySQL server host. Prüfe das gegen.
by Oliver Georgi
Sat 18. May 2019, 00:58
Forum: hacks & enhancements Support
Topic: Navi Script {NAV_VERT_FO:ID,Depth} nicht mit PHP 7 kompatibel
Replies: 39
Views: 2224

Re: Navi Script {NAV_VERT_FO:ID,Depth} nicht mit PHP 7 kompatibel

<?php $content["all"] = preg_replace_callback('/\{D:(.*?)\}/i', 'myRT1', $content["all"]); function myRT1($rtinfo) { $dateImage = ''; $rtinfo = explode(',', $rtinfo[1]); $startDate = strtotime($rtinfo[0]); $timeout = isset($rtinfo[1]) ? intval($rtinfo[1]) : 0; $timeout = $timeout * 24 * 3600; if(ti...
by Oliver Georgi
Tue 14. May 2019, 11:09
Forum: hacks & enhancements Support
Topic: Navi Script {NAV_VERT_FO:ID,Depth} nicht mit PHP 7 kompatibel
Replies: 39
Views: 2224

Re: Navi Script {NAV_VERT_FO:ID,Depth} nicht mit PHP 7 kompatibel

phpwcms läuft mit neuestem PHP-Release, also 7.3 ist OK. Ältere Scripte müssen natürlich angepasst werden.

Für preg_replace_callback() empfehlen sich unter anderem dann anonyme Funktionen.
by Oliver Georgi
Mon 13. May 2019, 13:19
Forum: phpwcms Support Deutsch
Topic: NEWS_TAGS und das Komma dazwischen
Replies: 6
Views: 461

Re: NEWS_TAGS und das Komma dazwischen

kommt direkt aus der DB. Schreibe Dir eigenen Ersetzer. [NEWS_TAGS][STRIP_COMMA] {NEWS_TAGS}[/STRIP_COMMA][/NEWS_TAGS] <?php if (strpos($content['all'], '[STRIP_COMMA]') !== false) { $content['all'] = preg_replace_callback('/\[STRIP_COMMA\](.*?)\[\/STRIP_COMMA\]/is', function ($match) {return str_re...
by Oliver Georgi
Mon 13. May 2019, 13:11
Forum: phpwcms Support Deutsch
Topic: Multilanguage-Site mit einem Template
Replies: 74
Views: 8133

Re: Multilanguage-Site mit einem Template

Und ich kann es nur noch mal wiederholen – ich kenne so gut wie kein Projekt, bei dem es irgendwie mehrsprachige Inhalte für alle Bereiche 1:1 gibt. Das ist aus meiner Sicht schlicht ein Idealbild, dass so gut wie kein Kunde durchhält. In aller Regel ist die Hauptseite gut gepflegt, die Zusatzsprach...
by Oliver Georgi
Mon 13. May 2019, 13:03
Forum: phpwcms Support Deutsch
Topic: Multilanguage-Site mit einem Template
Replies: 74
Views: 8133

Re: Multilanguage-Site mit einem Template

Warum doppelt? Eine deutsch eine englisch.
by Oliver Georgi
Mon 13. May 2019, 11:34
Forum: phpwcms Support Deutsch
Topic: NEWS_TAGS und das Komma dazwischen
Replies: 6
Views: 461

Re: NEWS_TAGS und das Komma dazwischen

Hier der CP News:
Bildschirmfoto 2019-05-13 um 11.32.51.png
Sprache wählen bzw. weitere Filter, falls erforderlich. Muss dann nur auf der betreffenden Seite integriert werden, die für die Newsdarstellung genutzt wird.